Bug 107966

Summary: NFS hangs kernel
Product: [Retired] Red Hat Linux Reporter: Alan Olsen <alan>
Component: kernelAssignee: Steve Dickson <steved>
Status: CLOSED CURRENTRELEASE QA Contact: Ben Levenson <benl>
Severity: high Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-06-16 00:57:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alan Olsen 2003-10-25 06:30:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030807

Description of problem:
H have a large file server that has four drives exported to the subnet I am on.
 On my Redhat 9 box, I mount all of those drives.  Then if I move files from one
exported file system to another (from one drive to another over the NFS mount)
the system will lock hard.  No messages in syslog.  No messages in syslog on the
other machine.  The system that is being mounted is fine.

This is consistant behaviour.  Sometimes I will get hangs when transfering large
quantities of files, but sometimes not.  Mount to mount kills the system dead.

The firewall is turned off.



Version-Release number of selected component (if applicable):
kernel-2.4.20-18.9 nfs-utils-1.0.5-1

How reproducible:
Always

Steps to Reproduce:
1. mount -t nfs 10.0.0.222:/export1 /mnt/export1
2. mount -t nfs 10.0.0.222:/export2 /mnt/export2
3. mv -v /mnt/export1/big-mess-o-files /mnt/export2
    

Actual Results:  Locks the system.

Expected Results:  Should move the files.

Additional info:

Comment 1 Steve Dickson 2004-06-16 00:57:38 UTC
I was unable to reproduce this problem with a more recent kernel
so I' closing this as fixed in current release.