Bug 1080028

Summary: Graphics issues with title bars and a number of drop-down dialog boxes in RHEL 7
Product: Red Hat Enterprise Linux 7 Reporter: Bill Sanford <bsanford>
Component: xorg-x11-serverAssignee: Dave Airlie <airlied>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 7.0CC: airlied, bsanford, tpelka, vbenes
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-19 04:19:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Snapshot of the title bar corruption none

Description Bill Sanford 2014-03-24 14:34:31 UTC
Created attachment 878084 [details]
Snapshot of the title bar corruption

Description of problem:
Graphics issues with title bars and a number of drop-down dialog boxes in RHEL 7 and xorg-x11-drv-ati. This is using the AMD Radeon HD 7770.

Version-Release number of selected component (if applicable):
RHEL-7.0-20140317.0
xorg-x11-drv-ati-7.2.0-9.20140113git3213df1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 RHEL Program Management 2014-04-01 05:47:22 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 2 Tomas Pelka 2015-05-12 08:16:42 UTC
Bill are you still able to reproduce on latest rhel7?

Thanks
-Tom

Comment 3 Dave Airlie 2015-05-28 05:46:17 UTC
this looks like a glamor bug, I've got a fix I'm sending upstream now.

Comment 5 Bill Sanford 2015-06-05 14:37:41 UTC
Tomas, as of RHEL-7.1-20150219.1, RHEL-7.2-20150519.n.0 and GNOME 3.14, this is still an issue.

Comment 6 Tomas Pelka 2015-06-05 15:33:25 UTC
(In reply to Bill Sanford from comment #5)
> Tomas, as of RHEL-7.1-20150219.1, RHEL-7.2-20150519.n.0 and GNOME 3.14, this
> is still an issue.

As Dave mentioned it is glamour issue so it might be fixed in packages from 7.2 xorg rebase repo: http://file.rdu.redhat.com/~btissoir/RHEL-7.2-xorg-rebase/

Please try when you get a chance.

-Tom

Comment 8 Bill Sanford 2015-09-22 15:30:52 UTC
Verified with RHEL-7.2-20150917.0 and xorg-x11-drv-ati-7.5.0-3.el7

Comment 9 errata-xmlrpc 2015-11-19 04:19:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2198.html