Bug 1080225

Summary: May we please have a clipit for EPEL
Product: [Fedora] Fedora Reporter: Todd <ToddAndMargo>
Component: clipitAssignee: Nikos Roussos <comzeradd>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 20CC: comzeradd
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: clipit-1.4.2-6.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-05-24 18:01:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Todd 2014-03-25 00:35:54 UTC
May we please have a Clipit for EPEL?

The following does rebuild:

# rpmbuild --rebuild clipit-1.4.2-5.fc20.src.rpm

Many thanks, -T

Comment 1 Todd 2014-03-25 00:37:07 UTC
Well, almost:

/root/rpmbuild/BUILDROOT/clipit-1.4.2-5.fc20.x86_64/etc/xdg/autostart/clipit-startup.desktop: error: value "GNOME;XFCE;LXDE;Unity;MATE;" for key "OnlyShowIn" in group "Desktop Entry" contains an unregistered value "MATE"; values extending the format should start with "X-"
Error on file "/root/rpmbuild/BUILDROOT/clipit-1.4.2-5.fc20.x86_64/etc/xdg/autostart/clipit-startup.desktop": Failed to validate the created desktop file

Comment 2 Nikos Roussos 2014-03-26 12:55:46 UTC
Did you try to rebuild for epel6 to get this error or epel5? MATE seems to be an accepted keyword by the spec: http://standards.freedesktop.org/menu-spec/latest/apb.html

I don't know if it deserves the effort, since the project seems abandoned, but if the epel build doesn't nee much effort then I'll give it a try.

Comment 3 Todd 2014-03-26 17:46:41 UTC
Hi Nikos,

Tom over on the Scientific Linux mail list wrote me this:

-T

It builds OK with these changes (I removed appdata.xml because it's
only useful on F20):

[th@localhost ~]$ diff clipit.spec ./rpmbuild/SPECS/clipit.spec
10,13d9
< # clipit doesn't autostart in MATE
< # Fixed upstream but not yet merged
< Source1: %{name}.appdata.xml
< Patch0:        %{name}-%{version}-mate.patch
21a18
>
35c32
< %patch0 -p1 -b .orig
---
>
54d50
< install -m 644 %{SOURCE1}
%{buildroot}%{_datarootdir}/appdata/%{name}.appdata.xml
63a60
>
69a67
>
82d79
< %{_datarootdir}/appdata/%{name}.appdata.xml

[th@localhost ~]$ diff clipit-startup.desktop.in
./rpmbuild/BUILD/clipit-1.4.2/data/clipit-startup.desktop.in
8c8
< OnlyShowIn=GNOME;XFCE;LXDE;Unity;
---
> OnlyShowIn=GNOME;XFCE;

Comment 4 Todd 2014-04-05 03:44:57 UTC
I tried "Parcelllite".  It killed my ability to copy and paste images.   :'(

Any sigh of a port for this one yet?

Comment 5 Nikos Roussos 2014-04-28 12:32:51 UTC
Hi,

I'll try the patch for EPEL and I'll push it to repos.

Comment 6 Fedora Update System 2014-05-02 10:43:27 UTC
clipit-1.4.2-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/clipit-1.4.2-6.el6

Comment 7 Fedora Update System 2014-05-02 16:01:07 UTC
Package clipit-1.4.2-6.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing clipit-1.4.2-6.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1311/clipit-1.4.2-6.el6
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-05-24 18:01:42 UTC
clipit-1.4.2-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Todd 2014-05-31 17:56:45 UTC
Installed clipit in Scientific Linux 6.5, 64 bit and I am able to copy images with Gimp and Firefox, then exit all programs, start Thunderbird and Libre Office and successfully paste images. Yippee! Thank you!!! 

-T  (the original bug poster)