Bug 1082559

Summary: udisksd[2008]: Error probing device: Error sending ATA command IDENTIFY PACKET DEVICE to /dev/sr0
Product: Red Hat Enterprise Linux 7 Reporter: chuli
Component: qemu-kvm-rhevAssignee: John Snow <jsnow>
Status: CLOSED ERRATA QA Contact: FuXiangChun <xfu>
Severity: low Docs Contact:
Priority: low    
Version: 7.0CC: hhuang, huding, juzhang, michen, mrezanin, pbonzini, rbalakri, virt-maint
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: qemu 2.6.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-07 20:11:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description chuli 2014-03-31 10:36:04 UTC
Description of problem:

"
Apr  1 02:08:44 localhost udisksd[2008]: Error probing device: Error sending ATA command IDENTIFY PACKET DEVICE to /dev/sr0: ATA command failed: error=0x20 count=0x00 status=0x50 (g-io-error-quark, 0)
"
shown up in guest's /var/log/message after issue "eject" in guest on runlevel 5 

Version-Release number of selected component (if applicable):

Host info:
#cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.0 Beta (Maipo)

# uname -r
3.10.0-115.el7.x86_64

# rpm -qa|grep qemu
qemu-img-rhev-1.5.3-59.el7ev.x86_64
ipxe-roms-qemu-20130517-5.gitc4bce43.el7.noarch
qemu-kvm-common-rhev-1.5.3-59.el7ev.x86_64
qemu-kvm-rhev-debuginfo-1.5.3-59.el7ev.x86_64
qemu-kvm-tools-rhev-1.5.3-59.el7ev.x86_64
qemu-kvm-rhev-1.5.3-59.el7ev.x86_64

Guest info:
#cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.0 Beta (Maipo)

#rpm -qa|grep udev
libgudev1-208-9.el7.x86_64
python-gudev-147.2-7.el7.x86_64
python-pyudev-0.15-6.el7.noarch
system-config-printer-udev-1.4.1-16.el7.x86_64

#uname -r
3.10.0-115.el7.x86_64

# rpm -qa|grep gnome
gnome-shell-extension-places-menu-3.8.4-9.el7.noarch
gnome-user-docs-3.8.2-4.el7.noarch
gnome-initial-setup-0.13.1-4.el7.x86_64
rhn-setup-gnome-2.0.2-5.el7.noarch
gnome-python2-2.28.1-14.el7.x86_64
gnome-video-effects-0.4.0-6.el7.noarch
gnome-online-accounts-3.8.5-7.el7.x86_64
gnome-menus-3.8.1-4.el7.x86_64
gnome-python2-gnomevfs-2.28.1-14.el7.x86_64
gnome-shell-extension-common-3.8.4-9.el7.noarch
gnome-shell-extension-apps-menu-3.8.4-9.el7.noarch
gnome-terminal-3.8.4-8.el7.x86_64
gnome-weather-3.8.2-4.el7.x86_64
libgnomekbd-3.6.0-4.el7.x86_64
gnome-keyring-3.8.2-7.el7.x86_64
gnome-keyring-pam-3.8.2-7.el7.x86_64
gnome-icon-theme-symbolic-3.8.2.2-2.el7.noarch
gnome-session-3.8.4-11.el7.x86_64
gnome-settings-daemon-3.8.6.1-8.el7.x86_64
gnome-shell-extension-window-list-3.8.4-9.el7.noarch
gnome-settings-daemon-updates-3.8.6.1-8.el7.x86_64
gnome-classic-session-3.8.4-9.el7.noarch
gnome-session-xsession-3.8.4-11.el7.x86_64
gnome-documents-3.8.5-8.el7.x86_64
gnome-python2-canvas-2.28.1-14.el7.x86_64
libgnome-2.32.1-9.el7.x86_64
gnome-bluetooth-libs-3.8.2.1-3.el7.x86_64
libgnomeui-2.24.5-8.el7.x86_64
gnome-themes-standard-3.8.4-3.el7.x86_64
gnome-getting-started-docs-3.8.3.0.2-3.el7.noarch
gnome-shell-extension-launch-new-instance-3.8.4-9.el7.noarch
gnome-tweak-tool-3.8.1-7.el7.noarch
gnome-contacts-3.8.2-5.el7.x86_64
gnome-color-manager-3.8.2-6.el7.x86_64
gnome-boxes-3.8.3-8.el7.x86_64
gnome-calculator-3.8.2-4.el7.x86_64
gnome-bluetooth-3.8.2.1-3.el7.x86_64
gnome-python2-bonobo-2.28.1-14.el7.x86_64
gnome-backgrounds-3.8.1-3.el7.noarch
gnome-desktop3-3.8.4-3.el7.x86_64
gnome-shell-3.8.4-31.el7.x86_64
gnome-disk-utility-3.8.2-5.el7.x86_64
gnome-screenshot-3.8.3-3.el7.x86_64
gnome-dictionary-3.8.0-4.el7.x86_64
libgnomecanvas-2.30.3-8.el7.x86_64
libgnome-keyring-3.8.0-3.el7.x86_64
gnome-icon-theme-extras-3.6.2-3.el7.noarch
gnome-abrt-0.3.4-6.el7.x86_64
gnome-shell-extension-alternate-tab-3.8.4-9.el7.noarch
gnome-packagekit-3.8.2-10.el7.x86_64
gnome-clocks-3.8.2-8.el7.x86_64
gnome-font-viewer-3.8.0-3.el7.x86_64
gnome-system-monitor-3.8.2.1-5.el7.x86_64
gnome-system-log-3.8.1-5.el7.x86_64
gnome-vfs2-2.24.4-14.el7.x86_64
gnome-icon-theme-3.8.2-3.el7.noarch
gnome-python2-gnome-2.28.1-14.el7.x86_64
gnome-icon-theme-legacy-3.8.2-3.el7.noarch





How reproducible:
 100%

Steps to Reproduce:
1.install rhel 7 x86_64 guest 
2.boot guest as following cli
 /usr/libexec/qemu-kvm -M pc -S -cpu host -enable-kvm -m 3048 -smp 4,sockets=2,cores=2,threads=1 -no-kvm-pit-reinjection -usb -device usb-mouse,id=input0 -name install-test -uuid 13a0c3a4-0a5e-4c40-b470-098b4296b008 -rtc base=localtime,clock=host,driftfix=slew -drive file=/home/rhel7_0326.qcow2,if=none,id=drive-virtio-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop -device ide-drive,ver=mikeee,drive=drive-virtio-disk,id=virtio-disk,bootindex=0,bus=ide.0 -k en-us -boot menu=on -qmp tcp:0:4445,server,nowait -serial unix:/tmp/ttyS0,server,nowait -vnc :2 -monitor stdio -netdev tap,id='f123' -device e1000,netdev=f123 -drive file=/home/en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso,if=none,media=cdrom,readonly=on,format=raw,id=cdrom1 -device ide-drive,bus=ide.0,drive=cdrom1,id=device1

3.use remote-viewer to connect guest and log into UI by root

4.issue "mount |grep sr0" and check err in /var/log/messages

5.issue "umount /dev/sr0" and check err in /var/log/messages

6.issue "eject " and check err in /var/log/messages

Actual results:

1.guest install correctly

2.guest boot successfully

3.root login successfully

4./dev/sr0 on /run/media/root/GSP1RMCULXFRER_EN_DVD type udf (ro,nosuid,nodev,relatime,uid=0,gid=0,umask=77,iocharset=utf8,uhelper=udisks2)

no error in /var/log/messages
5.umount successfully and no error in /var/log/messages

6./var/log/messages:
Mar 31 18:28:51 localhost udisksd[1979]: Error probing device: Error sending ATA command IDENTIFY PACKET DEVICE to /dev/sr0: ATA command failed: error=0x20 count=0x00 status=0x50 (g-io-error-quark, 0)


Expected results:

no error in /var/log/messages after step 6

Additional info:

if i login guest by ssh rather than GUI by root,do the same steps from step 4 to step 6,then no err in /var/log/message

Comment 2 John Snow 2016-05-18 19:08:15 UTC
Appears to work just fine using RHEL 7.0 for the guest and qemu 2.6.0 for the host VM; expected to be fixed by rebase to qemu-kvm-rhev 2.6.x.

(Potentially fixed even earlier than this, or possibly even fixed by a udev/udisks fix, unknown.)

Moving to "post" for testing by QE using up-to-date packages to confirm fix for upcoming qemu-kvm-rhev release.

Comment 4 FuXiangChun 2016-09-16 00:18:44 UTC
According to comment0. verified this bug with latest qemu-kvm-rhev-2.1.2-24.

no found error message in /var/log/message

Comment 6 errata-xmlrpc 2016-11-07 20:11:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html