Bug 1083419

Summary: Missing dependency python-setuptools
Product: [Fedora] Fedora EPEL Reporter: Daniel Wagner <d.wagner>
Component: ansibleAssignee: Tim Bielawa <tbielawa>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: el6CC: a.badger, athmanem, kevin, kupo, maxim, tbielawa
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: ansible-1.5.5-1.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-05-03 15:26:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Daniel Wagner 2014-04-02 08:24:50 UTC
Description of problem:
Ansible 1.5.3-1.el6 requires python-setuptools to function. After updateing some of my servers I noticed that ansible did not function anymore. 
Error-Message:
Traceback (most recent call last):
  File "/usr/bin/ansible-playbook", line 22, in <module>
    import pkg_resources
ImportError: No module named pkg_resources

The reason was that the python-setuptools package was not installed on those machines.

Version-Release number of selected component (if applicable):
- ansible.noarch 1.5.3-1.el6

How reproducible:
Install ansible on a system on which python-setuptools was not installed before.

Steps to Reproduce:
1. Install ansible on a system where python-setuptools was not installed before.
2. Exec /usr/bin/ansible-playbook to get the error message and check yum deplist ansible for missing dependency.

Actual results:
# yum deplist ansible
Loaded plugins: fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * base: centos.intergenia.de
 * epel: mirror.fraunhofer.de
 * extras: mirror.skylink-datacenter.de
 * updates: mirror.skylink-datacenter.de
85 packages excluded due to repository priority protections
Finding dependencies:
package: ansible.noarch 1.5.3-1.el6
  dependency: python-httplib2
   provider: python-httplib2.noarch 0.7.7-1.el6
  dependency: python-paramiko
   provider: python-paramiko.noarch 1.7.5-2.1.el6
  dependency: python-jinja2
   provider: python-jinja2.x86_64 2.2.1-1.el6
  dependency: python-crypto2.6
   provider: python-crypto2.6.x86_64 2.6.1-1.el6
  dependency: /usr/bin/python
   provider: python.x86_64 2.6.6-51.el6
   provider: python.x86_64 2.6.6-52.el6
  dependency: python(abi) = 2.6
   provider: python.x86_64 2.6.6-51.el6
   provider: python.x86_64 2.6.6-52.el6
  dependency: PyYAML
   provider: PyYAML.x86_64 3.10-3.el6
  dependency: python-keyczar

Expected Results:
# yum deplist ansible
Loaded plugins: fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * base: centos.intergenia.de
 * epel: mirror.fraunhofer.de
 * extras: mirror.skylink-datacenter.de
 * updates: mirror.skylink-datacenter.de
85 packages excluded due to repository priority protections
Finding dependencies:
package: ansible.noarch 1.5.3-1.el6
  dependency: python-httplib2
   provider: python-httplib2.noarch 0.7.7-1.el6
  dependency: python-paramiko
   provider: python-paramiko.noarch 1.7.5-2.1.el6
  dependency: python-jinja2
   provider: python-jinja2.x86_64 2.2.1-1.el6
  dependency: python-crypto2.6
   provider: python-crypto2.6.x86_64 2.6.1-1.el6
  dependency: /usr/bin/python
   provider: python.x86_64 2.6.6-51.el6
   provider: python.x86_64 2.6.6-52.el6
  dependency: python(abi) = 2.6
   provider: python.x86_64 2.6.6-51.el6
   provider: python.x86_64 2.6.6-52.el6
  dependency: PyYAML
   provider: PyYAML.x86_64 3.10-3.el6
  dependency: python-keyczar
  dependency: python-setuptools
   provider: python-setuptools.noarch 0.6.10-3.el6

Comment 1 Toshio Ernie Kuratomi 2014-04-02 16:59:46 UTC
Good catch. Thanks.

Comment 2 Fedora Update System 2014-04-02 21:04:31 UTC
ansible-1.5.4-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ansible-1.5.4-1.el6

Comment 3 Fedora Update System 2014-04-03 17:40:10 UTC
Package ansible-1.5.4-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ansible-1.5.4-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1044/ansible-1.5.4-1.el6
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-04-07 15:26:59 UTC
ansible-1.5.4-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ansible-1.5.4-2.el6

Comment 5 Fedora Update System 2014-04-18 21:45:41 UTC
ansible-1.5.5-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ansible-1.5.5-1.el6

Comment 6 Fedora Update System 2014-05-03 15:26:57 UTC
ansible-1.5.5-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.