Bug 1089117

Summary: RFE: Support for network QoS setting in virt-manager
Product: Red Hat Enterprise Linux 7 Reporter: hongming <honzhang>
Component: virt-managerAssignee: Giuseppe Scrivano <gscrivan>
Status: CLOSED UPSTREAM QA Contact: Virtualization Bugs <virt-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.1CC: codong, dyuan, gscrivan, lcui, mzhan, tzheng, zsong
Target Milestone: rcKeywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-07 22:17:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description hongming 2014-04-18 02:26:24 UTC
Description of problem:
The network QoS feature has been completed since rhel6.2 . And rhel7.0 has implemented the new feature - support guaranteed minimum bandwidth "floor".
The feature has stabilized in libvirt so long.

rhel6.2: Bug 632760 - RFE: Support for network QoS
rhel7.0: Bug 837908 - [RFE] Extend libvirt network QoS to support guaranteed minimum bandwidth "floor"

Version-Release number of selected component (if applicable):
libvirt-1.1.1-29.el7.x86_64
virt-manager-0.10.0-18.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Edit ->  Connection Details -> Virtual Networks
2.
3.

Actual results:
No support for network QoS in virt-manager.

Expected results:
Support for network QoS setting in virt-manager

Additional info:

Comment 2 Giuseppe Scrivano 2014-07-07 22:17:56 UTC
fixed upstream with:

commit e44ee980aea8b445a78d4850abbf52bfd43f1c73
Author: Giuseppe Scrivano <gscrivan>
Date:   Wed Jun 25 12:36:46 2014 +0200

    virtManager: add QoS information for a network
    
    Add UI elements to display and modify QoS settings in the network
    details.
    
    Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1089117
    
    Signed-off-by: Giuseppe Scrivano <gscrivan>