Bug 1095895

Summary: Review Request: rubygem-rubyntlm - Ruby NTLM Authentication Library
Product: [Fedora] Fedora Reporter: Mo Morsi <mmorsi>
Component: Package ReviewAssignee: Nobody's working on this, feel free to take it <nobody>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: package-review, steve.traylen
Target Milestone: ---Flags: steve.traylen: fedora-review?
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: AwaitingSubmitter
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-31 09:22:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mo Morsi 2014-05-08 18:59:41 UTC
Spec URL: http://fedorapeople.org/~mmorsi/staging/rubygem-rubyntlm.spec
SRPM URL: http://fedorapeople.org/~mmorsi/staging/rubygem-rubyntlm-0.4.0-1.fc19.src.rpm
Description: Provides message creator and parser for NTLM authentication in Ruby.
Fedora Account System Username: mmorsi

Comment 1 Steve Traylen 2014-07-21 12:55:28 UTC
Hi,

##################################################
Could you update to latest guidelines.

In particualar the 

Requires: ruby(release)
Requires: ruby(rubygems)
Provides: rubygem(%{gem_name}) = %{version}

is not needed for > fc21
##################################################
 
rubygem(simplecov) is now available so maybe add this
back into the tests.

##################################################
$ rpmlint ../SRPMS/rubygem-rubyntlm-0.4.0-1.fc20.src.rpm 
rubygem-rubyntlm.src: W: strange-permission rubyntlm-0.4.0.gem 0444L

easy enough to clean up.

#################################################

$ rpmlint ../RPMS/noarch/rubygem-rubyntlm-*
rubygem-rubyntlm-doc.noarch: W: wrong-file-end-of-line-encoding /usr/share/gems/gems/rubyntlm-0.4.0/examples/smtp.rb
rubygem-rubyntlm-doc.noarch: W: wrong-file-end-of-line-encoding /usr/share/gems/gems/rubyntlm-0.4.0/examples/http.rb
rubygem-rubyntlm-doc.noarch: W: wrong-file-end-of-line-encoding /usr/share/gems/gems/rubyntlm-0.4.0/examples/imap.rb
rubygem-rubyntlm-doc.noarch: W: wrong-file-end-of-line-encoding /usr/share/gems/gems/rubyntlm-0.4.0/README.md
2 packages and 0 specfiles checked; 0 errors, 4 warnings.

#################################################

Other than that all seems good, the licensing is good and clear.

Comment 2 Steve Traylen 2017-05-31 09:22:03 UTC
So old, can't remember by why I wanted it. Apologies for the lack of response.