Bug 1096286

Summary: "docker top all" doesn't show processes when --tty=false
Product: Red Hat Enterprise Linux 7 Reporter: Lukas Doktor <ldoktor>
Component: dockerAssignee: Lokesh Mandvekar <lsm5>
Status: CLOSED CURRENTRELEASE QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 7.0CC: admiller, cevich, dwalsh, golang-updates, jkeck, lsm5, mattdm, mgoldman, skottler, vbatts
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1088259 Environment:
Last Closed: 2014-06-03 15:04:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1088259    
Bug Blocks:    

Description Lukas Doktor 2014-05-09 15:11:25 UTC
+++ This bug was initially created as a clone of Bug #1088259 +++
After using the same magic required for the upstream docker 0.10 this behaves the same on RHEL docker-0.10.0-8.el7.x86_64

Description of problem:
Hi guys, when I run docker with --tty=false, the `docker top $NAME all` doesn't show any processes (just headers). When using only `docker top $NAME` it shows them...

Also the `ps` command inside container works, but `ps all` does not.

Version-Release number of selected component (if applicable):
docker-0.10.0-8.el7.x86_64
docker-io-0.9.0-3.fc20.x86_64


How reproducible:
always

Steps to Reproduce:
1. docker run -i --tty=false fedora bash
2. docker logs $NAME

Actual results:
F                   UID                 PID                 PPID                PRI                 NI                  VSZ                 RSS                 WCHAN               STAT                TTY                 TIME                COMMAND

Expected results:
F                   UID                 PID                 PPID                PRI                 NI                  VSZ                 RSS                 WCHAN               STAT                TTY                 TIME                COMMAND
1                   0                   24006               23954               20                  0                   11732               540                 -                   R                   pts/14              0:00                bash

--- Additional comment from Lukas Doktor on 2014-05-05 03:41:35 EDT ---

Can't reproduce with the upstream Docker version 0.10.0, build dc9c28f/0.10.0 top doesn't work at all (due of https://bugzilla.redhat.com/show_bug.cgi?id=1088125 )

--- Additional comment from Lukas Doktor on 2014-05-05 03:46:07 EDT ---

OK I moved it to the old cgroup location and the results are the same. So booth, fedora docker-io-0.9.0-3.fc20.x86_64 and upstream dc9c28f/0.10.0 are unable to list processes using `all` argument in non-tty mode.

Comment 2 Lukas Doktor 2014-05-29 11:18:41 UTC
I'm sorry there is a typo in reproducer:

Steps to Reproduce:
1. docker run -i --tty=false fedora bash
2. docker top $NAME all

Comment 3 Daniel Walsh 2014-05-29 13:04:50 UTC
I got other parameters to show with the ps command

-x
and 
-Z

Worked fine.

Comment 4 Lukas Doktor 2014-06-03 15:04:13 UTC
Hi Daniel, this issue seems to be fixed in docker-0.11.1-10.el7.x86_64. Thank you.