Bug 10999

Summary: libpng from RH6.2 causes segfaults with xpaint
Product: [Retired] Red Hat Linux Reporter: gezna
Component: libpngAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-06-11 06:49:32 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description gezna 2000-04-23 05:12:56 EDT
After freshly installing RH6.2 xpaint would segfault when opening or saving
PNG files. Since back-levelling xpaint to the RH6.1 version did not help I
searched through xpaint's dependencies: I saw one on libpng.so.2 so I tried
back-levelling THAT to the RH6.1 versions. I used:

rpm -U --oldpackage libpng-1.0.3-4.i386.rpm libpng-devel-1.0.3-4.i386.rpm

This solved the problem, so I upgraded xpaint again to the RH6.2 version to
verify that all was still well. It was...
I suspect that the libpng's shipped with RH6.2 are buggy...

Kind regards, Pim Vijfhuizen.
Comment 1 gezna 2000-06-11 06:49:32 EDT
Is anyone looking into this bug? It appears rather quiet around this one...

Pim
Comment 2 Bernhard Rosenkraenzer 2000-07-19 14:31:33 EDT
This is fixed in rawhide. (The problem was not a bug in libpng but a
source-level incompatible change, and xpaint requiring the old behavior).