Bug 1100267

Summary: Transaction check error while installing ovirt-engine
Product: [Fedora] Fedora Reporter: Ankit Kumar Honey <ankithoney>
Component: sosAssignee: Bryn M. Reeves <bmr>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 20CC: ankithoney, bmr, kroberts
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: sos-3.1-1.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-27 02:21:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ankit Kumar Honey 2014-05-22 11:53:00 UTC
Description of problem:
I am trying to install ovirt-engine on the fresh fedora 20 OS but it
fails with the Transaction check error. The error which I am getting
is mentioned below.


Version-Release number of selected component (if applicable):
ovirt-engine 3.4
Fedora OS 20

How reproducible:

Steps to Reproduce:
1. Install Fedora 20 on a machine/VM
2. Open the terminal --> Become a root user
3. yum -y update
4. yum install http://plain.resources.ovirt.org/pub/yum-repo/ovirt-release34.rpm
5. yum -y install ovirt-engine


Actual results:

Transaction check error:
  file /usr/lib/python2.7/site-packages/sos/plugins/postgresql.py from install of ovirt-log-collector-3.4.2-1.fc20.noarch conflicts with file from package sos-3.0-3.fc20.noarch
  file /usr/lib/python2.7/site-packages/sos/plugins/postgresql.pyc from install of ovirt-log-collector-3.4.2-1.fc20.noarch conflicts with file from package sos-3.0-3.fc20.noarch
  file /usr/lib/python2.7/site-packages/sos/plugins/postgresql.pyo from install of ovirt-log-collector-3.4.2-1.fc20.noarch conflicts with file from package sos-3.0-3.fc20.noarch


Expected results:
The ovirt-engine should install successfuly with all its dependent packages.

Additional info:

I tried the below steps mentioned from the redhat as well as fedora mailchain but getting the same error metioned above:

Steps:
1. Installing first sos doing:
    #yum install sos

2. Downgrade to lower version 
    # yum downgrade sos   

3. Add the below line in /etc/yum.conf   
     exclude=sos

4. And then repeating:
    #yum install ovirt-engine ovirt-guest-agent

Comment 1 Bryn M. Reeves 2014-05-23 10:00:08 UTC
This happens because the ovirt-log-collector package includes files that conflict with the plugins provided by the upstream sos project.

We're working to get the remaining oVirt pieces upstream and will then update the F19/20/rawhide packages so that these plugins are provided by the main sos rpm, resolving the conflict.

The major work for this is now complete:

 https://github.com/sosreport/sos/commit/e3dcb7e

I'll coordinate with Sandro to get these updates pushed out together shortly.

Comment 2 Fedora Update System 2014-06-17 23:11:17 UTC
sos-3.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sos-3.1-1.fc20

Comment 3 Fedora Update System 2014-06-18 22:22:42 UTC
Package sos-3.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sos-3.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7479/sos-3.1-1.fc20
then log in and leave karma (feedback).

Comment 4 Ankit Kumar Honey 2014-06-23 10:38:19 UTC
Thank You for your support.
I too my test it at my side and will update here.

Comment 5 Fedora Update System 2014-06-27 02:21:20 UTC
sos-3.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.