Bug 1101535

Summary: Buttons remain hidden when switching tab during compute profile edit on compute resource page
Product: Red Hat Satellite 6 Reporter: Martin Korbel <mkorbel>
Component: WebUIAssignee: Tomer Brisker <tbrisker>
Status: CLOSED ERRATA QA Contact: Kedar Bidarkar <kbidarka>
Severity: low Docs Contact:
Priority: medium    
Version: 6.0.3CC: bkearney, dcleal, dmitri, jmontleo, kbidarka, mkorbel, mmccune, ohadlevy
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-27 08:40:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Martin Korbel 2014-05-27 12:47:37 UTC
Description of problem:
When We open a detail of "Compute profile" in "Compute Resource", buttons "Associate VMs", "Edit", "New Image" are hidden. But buttons still hidden, when we switch tab (ex. "Images").


Version-Release number of selected component (if applicable):
foreman-1.6.0.9-1.el6sat

How reproducible:
100%

Steps to Reproduce:
1. We have got Sat6.0 with some compute resource (in my case EC2)
2. Open detail of our compute resource and click on "Compute profile"
3. Open detail of some "Compute profile" (in my case 1-small)
4. We can see, that buttons are hidden. (I think, better choice would be disabled of them)
5. Click on another tab (ex. "Images"). Buttons are still hidden !!!
6. We have to click back on "Compute profile" and close a detail (using a small gray icon X on right side of window).

Actual results:
This is not very intuitive.

Expected results:
I think, We have two ways of solutions:
1. We can use popup modal window (when we open detail of "Compute profile", all others parts of page will be disabled / gray)
2. Buttons are still displayed (may be some of them disabled). When we click on another tab, detail of "Compute profile" would be closed.

Additional info:

Comment 1 RHEL Product and Program Management 2014-05-27 13:03:54 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-05-27 13:25:56 UTC
Created redmine issue http://projects.theforeman.org/issues/5939 from this bug

Comment 4 Bryan Kearney 2014-06-25 12:03:01 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/5939 has been closed

Comment 7 Martin Korbel 2014-09-01 09:23:25 UTC
My above problem was solved. It is good job.
But I have detected a new problem with this fix and it is regression.

When I closed the compute profile detail by the cross or "Cancel" button, I don't able to click to other tabs "Compute Resource, Virtual Machines, Images". They are not disabled, but probably there missing the JS events.


Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140827.0 (foreman-1.6.0.42-1.el6sat)

Comment 8 Bryan Kearney 2015-01-09 14:39:08 UTC
Upstream bug assigned to ddolguik@redhat.com

Comment 9 Bryan Kearney 2015-08-25 17:56:46 UTC
Upstream bug component is Provisioning

Comment 10 Bryan Kearney 2015-08-25 17:58:21 UTC
Upstream bug component is WebUI

Comment 11 Bryan Kearney 2016-02-02 11:13:20 UTC
Upstream bug assigned to ddolguik@redhat.com

Comment 12 Bryan Kearney 2016-02-02 11:13:22 UTC
Upstream bug component is WebUI

Comment 13 Tomer Brisker 2016-03-08 12:12:59 UTC
If I understood correctly the second issue raised here, it is not reproducible currently in Foreman 1.11, meaning it is fixed for 6.2. Moving to ON_QA for verification.
In the future, please do not reuse bugs for further issues once the original issue has been resolved, instead open a new bug and link it to any related bugs.

Comment 15 Kedar Bidarkar 2016-04-18 12:27:30 UTC
Please provide verification steps. 

This bug being very old it becomes difficult to figure what exactly needs to be verified here.


Upon eiditing the compute profile as mentioned above we can see,
a) Compute-Profile
b) Compute Resource, both select boxes greyed and disabled.

I think the UI is now very different and this bug may be moved to VERIFIED sate.

TESTED with sat62-snap8.1

Comment 16 Kedar Bidarkar 2016-04-20 14:42:23 UTC
This was verified by,

a) Navigating to CR, then show page, compute profile.
b) clicking the compute profile which is not associated open a open another pane and the page would be in two-pane style.
c) Now clicking the X or cancel button, we can select the various other tabs too.

VERIFIED with sat62-snap8.1

Comment 18 errata-xmlrpc 2016-07-27 08:40:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500