Bug 1101847

Summary: Add LVM Support to kdump
Product: [Fedora] Fedora Reporter: Joseph D. Wagner <joe>
Component: kexec-toolsAssignee: Baoquan He <bhe>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: rawhideCC: bhe, chaowang, ruyang
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-05-29 05:41:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joseph D. Wagner 2014-05-28 04:50:37 UTC
The default installation uses LVM.  However, kdump does not support LVM, meaning that kdump does not support the default installation.  I do not believe this is an acceptable combination of defaults and features.  (This is particularly problematic if the cause of the kernel crash is located in the storage subsystem.)

Let me give you the example of a small business customer who is paying for support.  They start to experience intermittent kernel dumps.  The fastest way to approach this would be to reconfigure the server to collect dumps which could be sent to the support teams.  However, they cannot because they followed the default installation which uses LVM; a small business could find it difficult and time-consuming to repurpose a spare computer as a netdump server (they might not have a spare); and a small business may have a relatively slow internet connection, like ISDN or a slow DSL/Cable, making online/live/cloud solutions impractical.

I believe making kdump work out-of-the-box with the default configuration will have benefits for developers and their support teams, as well as small business customers who need rapid, low-intervention solutions.

Thank you for your consideration.

Comment 1 WANG Chao 2014-05-28 08:06:48 UTC
How is LVM dump target not working for you? Can you give us an example?

Comment 2 Joseph D. Wagner 2014-05-29 05:41:12 UTC
It must have been a configuration issue.  It works for me now.  Sorry about that.