Bug 1105023

Summary: perl-IO-Event-0.813-1.fc21 FTBFS: t/forked2.t fails under heavy load
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: perl-IO-EventAssignee: Petr Pisar <ppisar>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: emmanuel, perl-devel
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: perl-IO-Event-0.813-7.fc25 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-02-24 18:11:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Petr Pisar 2014-06-05 08:45:42 UTC
perl-IO-Event-0.813-1.fc21 fails t/forked2.t test if the host is under heavy load:

# Looks like you planned 115 tests but ran 111.
print 960: Connection reset by peer
Compilation failed in require at t/forked2.t line 5.
t/forked2.t ..... 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed

Comment 1 Emmanuel Seyman 2014-11-20 09:41:37 UTC
Given that this issue is an upstream bug more than it is a packaging issue, I'll be keeping track of it in CPAN's RT. Accordingly, I'm closing this bug with the resolution of UPSTREAM.

Comment 2 Petr Pisar 2016-02-24 16:12:21 UTC
Debian provided a patch that fixes the race according to my humble tests. I still encounter this issue occasionally, so I will apply the patch onto Rawhide.