Bug 1107333

Summary: --clipout option doesn't warn when xsel isn't installed
Product: [Fedora] Fedora Reporter: Mike Ruckman <mruckman>
Component: fpasteAssignee: Ankur Sinha (FranciscoD) <sanjay.ankur>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: high    
Version: 19CC: athmanem, metherid, sanjay.ankur
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: fpaste-0.3.7.3-1.fc19 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-13 05:28:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike Ruckman 2014-06-09 23:07:52 UTC
Description of problem:
Running `fpaste --clipout foo.txt` warns "WARNING: URL not saved to clipboard." instead of letting the user know they need xsel for that feature to work.

Version-Release number of selected component (if applicable):
fpaste-0.3.7.2-1.fc19.noarch

How reproducible:
Always

Steps to Reproduce:
1. run fpaste with the --clipout option
2.
3.

Actual results:
Warn that nothing was copied to clipboard

Expected results:
Warn that required package isn't installed

Additional info:
This doesn't break anything, but also doesn't let the user know what went wrong.

Comment 1 Ankur Sinha (FranciscoD) 2014-06-10 01:34:15 UTC
Hi Mike,

Thanks for the bug report. I thought there was an error message asking the user to install xsel. I'll check up and push an update ASAP.

Warm regards,
Ankur

Comment 2 Mike Ruckman 2014-06-10 03:09:11 UTC
No problem. It looks like it was commented out [0]. I was going to work on a patch tomorrow - but if you've got it then I'll let you do your thing :)

// Mike

[0] https://git.fedorahosted.org/cgit/fpaste.git/tree/fpaste#n651

Comment 3 Fedora Update System 2014-06-10 06:33:03 UTC
fpaste-0.3.7.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fpaste-0.3.7.3-1.fc20

Comment 4 Fedora Update System 2014-06-10 06:33:10 UTC
fpaste-0.3.7.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fpaste-0.3.7.3-1.fc19

Comment 5 Fedora Update System 2014-06-11 16:24:43 UTC
Package fpaste-0.3.7.3-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fpaste-0.3.7.3-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7239/fpaste-0.3.7.3-1.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-06-13 05:28:50 UTC
fpaste-0.3.7.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-06-21 02:57:00 UTC
fpaste-0.3.7.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.