Bug 1111051

Summary: [virtio-win][netkvm]win7-32 guest bsod(8e) while performing long (several hours) netperf transfer with mq=on
Product: Red Hat Enterprise Linux 7 Reporter: lijin <lijin>
Component: virtio-winAssignee: Dmitry Fleytman <dfleytma>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: high Docs Contact:
Priority: high    
Version: 7.0CC: ghammer, hhuang, knoel, lijin, mdeng, michen, rbalakri, virt-maint, vrozenfe, yvugenfi
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
NO_DOCS
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-24 08:42:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
analyze -v info for the first bsod
none
analyze -v info for the second bsod
none
analyze -v info for the third bsod none

Description lijin 2014-06-19 06:56:16 UTC
Description of problem:
win7-32 guest bsod(8e) while performing long (several hours) transfer with netperf

Version-Release number of selected component (if applicable):
virtio-win-prewhql-86
qemu-kvm-rhev-1.5.3-60.el7ev.x86_64
kernel-3.10.0-123.el7.x86_64
spice-server-0.12.4-5.el7.x86_64

How reproducible:
3/3

Steps to Reproduce:
1.boot win7-32 guest:
/usr/libexec/qemu-kvm -cpu SandyBridge -m 2G -smp 2 -usb -device usb-tablet -boot menu=on -drive file=win7-32.qcow2,format=qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none,media=disk -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=b111a,path=/tmp/w2k8-R2-nic,server,nowait -mon chardev=b111a,mode=readline -name w2k8-R2-nic -monitor stdio -spice disable-ticketing,port=5900 -vga qxl -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -chardev socket,path=/tmp/tt-1-1,server,nowait,id=tt-1-1 -mon mode=readline,chardev=tt-1-1 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -qmp tcp::444,server -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,vectors=1,mq=on,netdev=hostnet0,mac=52-54-00-02-9a-80,id=net0

2.do netperf test in guest for a long time:
for /l %j in (1,1,100000) do 
  for /d %i in (32 64 128 256 512 1024 2048 4096 8192 16384 32768)
     do netperf.exe -H $SERVER_IP -c -C -t tcp_stream -f m -l 30s -- -m %i 
  done
done

Actual results:
guest bsod with 8e code

Expected results:
no bsod,network still alive after netperf test.

Additional info:
I tried three times,all bsod with 8e code,but there is a little difference in the windbg analyze info,I will uplode detailed info later.

Comment 1 lijin 2014-06-19 06:58:06 UTC
Created attachment 910274 [details]
analyze -v info for the first bsod

Comment 2 lijin 2014-06-19 06:58:58 UTC
Created attachment 910275 [details]
analyze -v info for the second bsod

Comment 3 lijin 2014-06-19 06:59:35 UTC
Created attachment 910276 [details]
analyze -v info for the third bsod

Comment 6 Yan Vugenfirer 2014-06-19 12:39:03 UTC
Do I understand correctly that driver verifier was enabled during the test?


Thanks,
Yan.

Comment 7 lijin 2014-06-20 02:11:28 UTC
(In reply to Yan Vugenfirer from comment #6)
> Do I understand correctly that driver verifier was enabled during the test?
> 
> 
> Thanks,
> Yan.

yes,I enabled the driver verifier during the test.
And yesterday I tried boot guest with virtio-net-pci without mq=on,guest works fine after 10 hours netperf,no bsod

Comment 8 Yan Vugenfirer 2014-06-22 07:27:46 UTC
(In reply to lijin from comment #7)
> (In reply to Yan Vugenfirer from comment #6)
> > Do I understand correctly that driver verifier was enabled during the test?
> > 
> > 
> > Thanks,
> > Yan.
> 
> yes,I enabled the driver verifier during the test.
> And yesterday I tried boot guest with virtio-net-pci without mq=on,guest
> works fine after 10 hours netperf,no bsod

Thank you for the information.

Comment 9 Yan Vugenfirer 2014-06-22 07:44:04 UTC
Hi,

Could you please test build 82 (https://brewweb.devel.redhat.com/buildinfo?buildID=355375) to check if it is a regression?

Thank you,
Yan.

Comment 10 lijin 2014-06-23 01:16:06 UTC
(In reply to Yan Vugenfirer from comment #9)
> Hi,
> 
> Could you please test build 82
> (https://brewweb.devel.redhat.com/buildinfo?buildID=355375) to check if it
> is a regression?
> 
> Thank you,
> Yan.

OK,I will update the result after the test finish,might need a few hours.

Comment 11 lijin 2014-06-23 08:09:50 UTC
(In reply to Yan Vugenfirer from comment #9)
> Hi,
> 
> Could you please test build 82
> (https://brewweb.devel.redhat.com/buildinfo?buildID=355375) to check if it
> is a regression?
> 
> Thank you,
> Yan.

try with build82 twice,hit this issue once,so it's not a regression bug

Comment 12 Yan Vugenfirer 2014-06-23 09:20:10 UTC
Thanks!

Comment 13 Mike Cao 2014-06-27 10:11:08 UTC
Pls retest it w/ virtio-win-1.7-1 to see whether it is a regression to customers

Comment 14 lijin 2014-07-02 02:37:41 UTC
(In reply to Mike Cao from comment #13)
> Pls retest it w/ virtio-win-1.7-1 to see whether it is a regression to
> customers

retest twice with virtio-win-1.7.1-1.el7.noarch,guest works well,no bsod

Comment 16 lijin 2014-09-28 02:43:25 UTC
retest with build 92,steps same as comment#0,after more than 10 hours' netperf testing,guest still works well

package info:
kernel-3.10.0-165.el7.x86_64
qemu-kvm-rhev-2.1.0-4.el7.x86_64
seabios-1.7.5-5.el7.x86_64
spice-server-0.12.4-5.el7.x86_64
virtio-win-prehql-92

Comment 19 Mike Cao 2014-10-09 03:04:05 UTC
Move to verified according to comment #16

Comment 24 errata-xmlrpc 2015-11-24 08:42:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html