Bug 1113380

Summary: May we have an RPM of Librecad?
Product: [Fedora] Fedora EPEL Reporter: Todd <ToddAndMargo>
Component: librecadAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: el6CC: hobbes1069, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-09 17:57:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Todd 2014-06-26 05:01:47 UTC
Hi,

May we have an EPEL 6.x spin of Librecad?  Fedora 20 is currently on librecad-2.0.4-1.fc20.src.rpm

Many thansk,
-T

rpmbuild --rebuild librecad-2.0.4-1.fc20.src.rpm
...
cc1plus: error: unrecognized command line option "-std=c++11"cc1plus: error: unrecognized command line option "-std=c++11"

cc1plus: error: unrecognized command line option "-std=c++11"

Comment 1 Tom "spot" Callaway 2014-07-07 17:18:27 UTC
I'm working on this for el6, delayed due to lack of dependencies in epel-6.

It is however, now built for epel-7.

Comment 2 Tom "spot" Callaway 2014-07-09 17:57:51 UTC
... and after finally getting all the deps in place, discovering that the RHEL 6 toolchain/libraries are too old to properly build librecad. Sorry, going to have to close this as CANTFIX.

Comment 3 Richard Shaw 2014-07-09 18:14:50 UTC
I get CC'd on on the koji builds for librecad and I usually feel bad when I'm abusing the build server!

The only option is probably a COPR repository? Ideally the dependencies that are tool old could be built as parallel installable or static only?

Comment 4 Tom "spot" Callaway 2014-07-09 18:24:46 UTC
Maybe. I got it down to some odd C++ constructs that I admittedly don't entirely understand that clearly work with modern gcc. I had to pass CXX_CPP11_FLAG=-std=c++0x just to get it to even attempt to build on RHEL 6.

I've left the work in the el6 branch in git in case you want to take a crack at it.

(Apologies for the build spam. I'm not exactly gentle with koji. :) )

Comment 5 Todd 2014-11-15 03:09:42 UTC
$ su root -c "rpm -Uvh LibreOffice_4.3.4.1_Linux_x86-64_rpm/RPMS/*.rpm"
Password: 

error: Failed dependencies:
        libobasis4.3-en-US <= 4.3.3.2-2 is needed by (installed) libobasis4.3-en-US-help-4.3.3.2-2.x86_64

But it is not missing:
      $ rpm -qa libobasis4.3-en-US
      libobasis4.3-en-US-4.3.3.2-2.x86_64

That sure look "<= 4.3.3.2-2" to me.

Comment 6 Tom "spot" Callaway 2014-11-17 15:54:18 UTC
I'm really not sure how you ended up here, this is a closed bug on Librecad (not LibreOffice). That said, I'm going to try to guess at your issue:

You're updating from a directory full of rpms for LibreOffice 4.3.4.1. What the error is saying is that in the transaction, libobasis4.3-en-US gets updated from 4.3.3.2 to 4.3.4.1, but libobasis4.3-en-US-help does not, leaving it with an unresolved dependency on the old libobasis4.2-en-US (4.3.3.2), and failing the transaction (because you don't want broken dependencies).

I would look in that directory and see if libobasis4.3-en-US-help is in there, I suspect it is missing. If that package went away in 4.3.4.1, it _should_ have been properly Provided/Obsoleted by something else in the package set (likely libobasis4.3-en-US), but since that clearly isn't happening, you might have to manually remove libobasis4.3-en-US-help before trying to update again:

   su root -c "rpm -e libobasis4.3-en-US-help"

But I'm betting that package is still there and just didn't get downloaded into your directory for some reason.

Hope that helps.

Comment 7 Todd 2014-11-17 22:37:29 UTC
(In reply to Tom "spot" Callaway from comment #6)
> I'm really not sure how you ended up here, this is a closed bug on Librecad
> (not LibreOffice). That said, I'm going to try to guess at your issue:
> 
> You're updating from a directory full of rpms for LibreOffice 4.3.4.1. What
> the error is saying is that in the transaction, libobasis4.3-en-US gets
> updated from 4.3.3.2 to 4.3.4.1, but libobasis4.3-en-US-help does not,
> leaving it with an unresolved dependency on the old libobasis4.2-en-US
> (4.3.3.2), and failing the transaction (because you don't want broken
> dependencies).
> 
> I would look in that directory and see if libobasis4.3-en-US-help is in
> there, I suspect it is missing. If that package went away in 4.3.4.1, it
> _should_ have been properly Provided/Obsoleted by something else in the
> package set (likely libobasis4.3-en-US), but since that clearly isn't
> happening, you might have to manually remove libobasis4.3-en-US-help before
> trying to update again:
> 
>    su root -c "rpm -e libobasis4.3-en-US-help"
> 
> But I'm betting that package is still there and just didn't get downloaded
> into your directory for some reason.
> 
> Hope that helps.

Thank you!