Bug 1114483

Summary: [py] string provides filter not working
Product: [Fedora] Fedora Reporter: Parag Nemade <pnemade>
Component: hawkeyAssignee: Ales Kozumplik <akozumpl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: akozumpl, jzeleny, pnemade, rholy, tla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dnf-plugins-core-0.1.1-2.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-09 02:30:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Parag Nemade 2014-06-30 08:15:17 UTC
Description of problem:

Following is a example where I am not getting any results for filter(provides='kde-l10n-cs') function call

=======================================================
import dnf

db = dnf.Base()
db.conf.releasever = None
db.read_all_repos()
db.repos.iter_enabled()
sack = db.fill_sack()

q = db.sack.query()
q = q.available()
q = q.filter(provides='kde-l10n-cs')
for pkg in q:
    print(pkg.name)

=======================================================

Version-Release number of selected component (if applicable):
dnf-0.5.2-1.fc20.noarch
dnf-plugins-core-0.1.0-2.fc20.noarch


How reproducible:
always

Comment 1 Ales Kozumplik 2014-06-30 08:21:16 UTC
Thanks, we'll take a look.

Comment 2 Ales Kozumplik 2014-07-01 08:15:50 UTC
This is probably a problem in hawkey reldep parsing.

Comment 3 Ales Kozumplik 2014-07-01 08:49:37 UTC
Fixed upstream in b957844.

Comment 4 Parag Nemade 2014-07-01 16:15:23 UTC
Ales, Can you please confirm me that when we get this fixed hawkey package in Fedora, will the given example in comment#0 work and give me kde-l10n-Czech as output?

Comment 5 Parag Nemade 2014-07-01 17:03:58 UTC
I just tried to package the current hawkey code on F20 and looks like given example is working fine now.

Thanks Ales.

Comment 6 Fedora Update System 2014-07-07 09:11:55 UTC
dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.3-1.fc20,hawkey-0.4.17-1.fc20,dnf-plugins-core-0.1.1-2.fc20

Comment 7 Fedora Update System 2014-07-08 01:04:18 UTC
Package dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.1-2.fc20 dnf-0.5.3-1.fc20 hawkey-0.4.17-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8167/dnf-0.5.3-1.fc20,hawkey-0.4.17-1.fc20,dnf-plugins-core-0.1.1-2.fc20
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-07-09 02:30:11 UTC
dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.