Bug 1114639

Summary: Using "run puppet" feature fails: undefined method `gsub' for #<Array ...>
Product: Red Hat Satellite Reporter: Bryan Kearney <bkearney>
Component: ProvisioningAssignee: Dominic Cleal <dcleal>
Status: CLOSED CURRENTRELEASE QA Contact: Katello QA List <katello-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.0.4CC: bbuckingham, cwelton, jmontleo
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
URL: http://projects.theforeman.org/issues/6402
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-11 12:23:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bryan Kearney 2014-06-30 14:21:19 UTC
<pre>
 
Warning!
undefined method `gsub' for #<Array:0x00000008e13478>

If you feel this is an error with Foreman itself, please open a new issue with Foreman ticketing system, You would probably need to attach the Full trace and relevant log entries.
NoMethodError
undefined method `gsub' for #<Array:0x00000008e13478>
app/controllers/application_controller.rb:172:in `error'
app/controllers/hosts_controller.rb:193:in `puppetrun'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'
</pre> 


Log from client:

<pre>
 puppet-agent[6949]: Forbidden request: foreman(10.0.0.10) access to /run/client.fqdn [save] authenticated  at :54
</pre>

Comment 1 Bryan Kearney 2014-06-30 14:21:21 UTC
Created from redmine issue http://projects.theforeman.org/issues/6402

Comment 3 Bryan Kearney 2014-07-23 00:03:39 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6402 has been closed
-------------
Dominic Cleal
Applied in changeset commit:b4fbdf574faf364fb1fc991c9363b3637ae70906.

Comment 6 Bryan Kearney 2014-09-11 12:23:40 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.