Bug 1114684

Summary: [abrt] mate-file-manager: handle_error(): caja killed by SIGTRAP
Product: [Fedora] Fedora Reporter: vijay <krishna2642>
Component: mate-file-managerAssignee: Dan Mashal <dan.mashal>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: dan.mashal, fedora, fedora, mailtopreetam, rdieter, stefano
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/e2fcccc2a998e81300c478a487d422423c527dee
Whiteboard: abrt_hash:5e56cb6e32cf6d92022a1e567dd5cb1975e28f05
Fixed In Version: caja-1.8.2-2.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-25 21:37:46 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: backtrace
none
File: cgroup
none
File: core_backtrace
none
File: dso_list
none
File: environ
none
File: limits
none
File: maps
none
File: open_fds
none
File: proc_pid_status
none
File: var_log_messages none

Description vijay 2014-06-30 12:06:15 EDT
Version-Release number of selected component:
mate-file-manager-1.6.4-4.fc20

Additional info:
reporter:       libreport-2.2.2
backtrace_rating: 4
cmdline:        /usr/bin/caja --no-default-window
crash_function: handle_error
executable:     /usr/bin/caja
kernel:         3.14.4-200.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 handle_error at xcb_io.c:213
 #5 handle_response at xcb_io.c:325
 #8 XCloseDisplay at ClDisplay.c:61
 #9 make_root_pixmap at mate-bg.c:1305
 #10 mate_bg_create_pixmap at mate-bg.c:1194
 #11 eel_background_ensure_realized at eel-background.c:363
 #12 eel_background_set_up_widget at eel-background.c:550
 #17 gtk_widget_realize at gtkwidget.c:3561
 #18 gtk_widget_map at gtkwidget.c:3435
 #19 gtk_scrolled_window_forall at gtkscrolledwindow.c:1082

Potential duplicate: bug 921552
Comment 1 vijay 2014-06-30 12:06:18 EDT
Created attachment 913467 [details]
File: backtrace
Comment 2 vijay 2014-06-30 12:06:19 EDT
Created attachment 913468 [details]
File: cgroup
Comment 3 vijay 2014-06-30 12:06:21 EDT
Created attachment 913469 [details]
File: core_backtrace
Comment 4 vijay 2014-06-30 12:06:22 EDT
Created attachment 913470 [details]
File: dso_list
Comment 5 vijay 2014-06-30 12:06:24 EDT
Created attachment 913471 [details]
File: environ
Comment 6 vijay 2014-06-30 12:06:25 EDT
Created attachment 913472 [details]
File: limits
Comment 7 vijay 2014-06-30 12:06:27 EDT
Created attachment 913473 [details]
File: maps
Comment 8 vijay 2014-06-30 12:06:28 EDT
Created attachment 913474 [details]
File: open_fds
Comment 9 vijay 2014-06-30 12:06:29 EDT
Created attachment 913475 [details]
File: proc_pid_status
Comment 10 vijay 2014-06-30 12:06:31 EDT
Created attachment 913476 [details]
File: var_log_messages
Comment 11 Wolfgang Ulbrich 2014-07-09 14:45:12 EDT
Can you describe a little more detailed what happend?
Did this issue occurs frequently ?
Any steps to reproduce?
Comment 12 Sergei S. Rublёv 2014-07-25 03:53:18 EDT
I get this bug along with bug 1051953 when I simply start caja in KDE with Alt+F2 or in Konsole. In Konsole I get this:


[ssr@ssr-rfremix ~]$ caja
Initializing caja-image-converter extension

(caja:13185): Gdk-ERROR **: The program 'caja' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 7 error_code 9 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Ловушка трассировки/останова (core dumped)
[ssr@ssr-rfremix ~]$
Comment 13 Wolfgang Ulbrich 2014-07-25 08:11:13 EDT
Hmm, from kde.
Seems there is a needed package missing maybe.
Did you do a full Mate installation or only installing caja?
Can you pls post
rpm -qa mate-\*
rpm -qa libmate\*
And can you run caja with gdb?
See http://fedoraproject.org/wiki/StackTraces#gdb
Comment 14 Sergei S. Rublёv 2014-07-26 13:50:29 EDT
I (currently) have Fedora 20 RFremix DVD MATE-spin and generally use MATE. But recently I have installed @kde-desktop over MATE. I had this bug for the first time when attaching/removing 2GB-flash card in MATE (not sure of details). Second time I got this bug after installing "yum install @kde-desktop" IN MATE (I can login to KDE instead of MATE at boot -- lightdm?). This bug is now reproducable in KDE -- just typing 'caja' in Konsole in KDE and it causes the above error and spawns ABRT.
Comment 15 Sergei S. Rublёv 2014-07-26 13:56:46 EDT
Here are my output for first 2 commands, and I'll do the "gdb" thing later (have no time right now):

==========

[ssr@ssr-rfremix ~]$ rpm -qa mate-\*
mate-utils-common-1.6.1-1.fc20.noarch
mate-backgrounds-1.6.1-1.fc20.noarch
mate-menus-libs-1.6.0-7.fc20.x86_64
mate-text-editor-1.6.2-1.fc20.x86_64
mate-panel-1.6.2-2.fc20.x86_64
mate-desktop-1.6.2-2.fc20.x86_64
mate-control-center-filesystem-1.6.2-3.fc20.x86_64
mate-notification-daemon-1.6.1-2.fc20.x86_64
mate-document-viewer-libs-1.6.2-3.fc20.x86_64
mate-calc-1.6.1-1.fc20.x86_64
mate-media-1.6.1-1.fc20.x86_64
mate-polkit-1.6.1-1.fc20.x86_64
mate-panel-libs-1.6.2-2.fc20.x86_64
mate-icon-theme-1.6.3-1.fc20.noarch
mate-session-manager-1.6.1-4.fc20.x86_64
mate-power-manager-1.6.3-2.fc20.x86_64
mate-file-manager-schemas-1.6.4-4.fc20.x86_64
mate-character-map-1.6.1-0.1.git2464a6c.fc20.x86_64
mate-control-center-1.6.2-3.fc20.x86_64
mate-window-manager-1.6.2-7.fc20.x86_64
mate-dialogs-1.6.2-1.fc20.x86_64
mate-file-manager-extensions-1.6.4-4.fc20.x86_64
mate-document-viewer-1.6.2-3.fc20.x86_64
mate-file-manager-image-converter-1.6.0-2.fc20.x86_64
mate-menus-1.6.0-7.fc20.x86_64
mate-menus-preferences-category-menu-1.6.0-7.fc20.x86_64
mate-system-monitor-1.6.1-1.fc20.x86_64
mate-netspeed-1.6.1-1.fc20.x86_64
mate-file-manager-1.6.4-4.fc20.x86_64
mate-menu-editor-1.6.1-1.fc20.noarch
mate-image-viewer-1.6.2-2.fc20.x86_64
mate-screenshot-1.6.1-1.fc20.x86_64
mate-document-viewer-caja-1.6.2-3.fc20.x86_64
mate-terminal-1.6.2-1.fc20.x86_64
mate-file-archiver-1.6.2-1.fc20.x86_64
mate-applets-1.6.2-1.fc20.x86_64
mate-themes-1.8.1-1.fc20.noarch
mate-search-tool-1.6.1-1.fc20.x86_64
mate-screensaver-1.6.2-1.fc20.x86_64
mate-settings-daemon-1.6.2-2.fc20.x86_64
mate-file-manager-sendto-1.6.0-2.fc20.x86_64
mate-icon-theme-faenza-1.6.1-0.1.gitc147867.fc20.noarch
mate-desktop-libs-1.6.2-2.fc20.x86_64

[ssr@ssr-rfremix ~]$ rpm -qa libmate\*
libmateweather-data-1.6.2-3.fc20.noarch                                                                                                                                                                        
libmatekbd-1.6.1-2.fc20.x86_64                                                                                                                                                                                 
libmatewnck-1.6.1-2.fc20.x86_64                                                                                                                                                                                
libmateweather-1.6.2-3.fc20.x86_64
Comment 16 Wolfgang Ulbrich 2014-07-26 14:07:33 EDT
It could be possible that caja tries to handle the desktop in kde which is the normal behaviour if you start caja without any option.
Try 'caja --no-desktop' in konsole.
mate-desktop-libs are installed, so all required gsettings schemas are there.
Comment 17 Sergei S. Rublёv 2014-07-26 14:16:01 EDT
Yes, "caja --no-desktop" doesn't cause Caja to crash^


====
[ssr@ssr-rfremix ~]$ caja --no-desktop
Initializing caja-image-converter extension
====

Caja works. And when I exit Caja it prints this and doesn't return me to bash:


====
(caja:4046): GLib-GObject-WARNING **: gsignal.c:2593: instance '0x1214600' has no handler with id '4387'

(caja:4046): GLib-GObject-WARNING **: gsignal.c:2593: instance '0xde0b80' has no handler with id '909'

(caja:4046): GLib-GObject-WARNING **: gsignal.c:2593: instance '0x1088720' has no handler with id '916'

(caja:4046): GLib-GObject-WARNING **: gsignal.c:2593: instance '0xe2dee0' has no handler with id '902'

(caja:4046): GLib-GObject-WARNING **: gsignal.c:2593: instance '0x15500a0' has no handler with id '4476'

(caja:4046): GLib-GObject-WARNING **: gsignal.c:2593: instance '0x14d0480' has no handler with id '4448'

(caja:4046): GLib-GObject-WARNING **: gsignal.c:2593: instance '0x7f5444001200' has no handler with id '4455'

(caja:4046): GLib-GObject-WARNING **: gsignal.c:2593: instance '0x1520360' has no handler with id '4462'

(caja:4046): GLib-GObject-WARNING **: gsignal.c:2593: instance '0x154e700' has no handler with id '4469'
Comment 18 Wolfgang Ulbrich 2014-07-26 15:02:18 EDT
Ok, so the issue is that the normal command without any options expect a running mate-session and mate-settings-deamon.
Note, ie. the background code is in all of those 3 packages.
I'm pretty shure that the warnings from your last post comes from that mate-session and mate-settings-deamon isn't running.
I saw those warnings also if  i run caja from the terminal with sudo.

root@mother rave]# sudo caja
Initializing caja-dropbox 1.6.1
Initializing caja-mdu extension
Initializing caja-open-terminal extension
Initializing caja-image-converter extension
sys:1: Warning: gsignal.c:2593: instance '0x16fc3a0' has no handler with id '1233'

Here mate-session and mate-settings-deamon as root process is also missing.

It would be helpfull if you could create a backtrace.
IMO caja should be able to run as standalone in another desktop without any option flag.
Maybe upstream agree with me.
Comment 19 Wolfgang Ulbrich 2014-07-26 15:06:32 EDT
PS: for the moment you can create a destop or panel starter in kde with the --no-desktop option to avoid the issue.
Comment 20 Wolfgang Ulbrich 2014-07-26 15:29:32 EDT
Forgot my last suggestion because this will end up in a open process if you use the desktop starter several times.

I use a desktop starter with the consolehelper command to start caja as root.

[root@mother rave]# ps aux | grep caja
rave     15396  0.4  1.0 1758640 89576 ?       Sl   21:17   0:02 caja
rave     15561  0.1  0.4 372376 36620 ?        Sl   21:25   0:00 caja-su --no-desktop /
root     15564  0.0  0.0 156600  4188 ?        S    21:25   0:00 /usr/sbin/userhelper -w caja-su --no-desktop /
root     15568  2.9  1.3 1221444 108488 ?      Sl   21:25   0:00 caja-su --no-desktop /
root     15664  0.0  0.0 112680  2356 pts/4    S+   21:25   0:00 grep --color=auto caja

After starting caja-su several times always one process is open.  :/
Comment 21 Sergei S. Rublёv 2014-07-27 10:21:55 EDT
I support the idea that Caja should work without crashes in KDE. I sometimes may use Caja in KDE and Dolphin in MATE.

I have played Caja around with different contexts in KDE when started in Konsole, as well as tried to run Caja in "gdb". I also switched several KDE/GTK window themes. Caja behaves differently and may print different ongoing "GTK" "critical"/"warning" errors in Konsole, and sometimes freezes the whole GUI -- that only Ctrl+Alt+Backspace helps.

When I finally set system KDE "Widget style" to "GTK+ Style" "caja" works well even with "no-desktop".
Comment 22 Sergei S. Rublёv 2014-07-27 13:05:01 EDT
Well, now I can definitely say that Caja fully crashes in KDE and produces bug 1114684 with KDE's:

System Settings → Application Appearance → GTK+ Appearance → Widget style
set to "oxygen-gtk" 
which is @kde-desktop/Fedora 20 default setting when @kde-desktop is newly installed.

When I switch "Widget style" to e.g. "Adwaita", Caja works and doesn't crash.
Comment 23 Wolfgang Ulbrich 2014-08-09 07:17:23 EDT
Ok, could you please file out a feature request with a detailed description at github.
https://github.com/mate-desktop/caja
Comment 24 Sergei S. Rublёv 2014-08-12 10:18:38 EDT
Made a report: https://github.com/mate-desktop/caja/issues/304
Comment 25 Fedora Update System 2015-01-21 13:58:30 EST
caja-1.8.2-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/caja-1.8.2-2.fc21
Comment 26 Fedora Update System 2015-01-21 13:58:36 EST
caja-1.8.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/caja-1.8.2-2.fc20
Comment 27 Fedora Update System 2015-01-25 21:33:51 EST
Package caja-1.8.2-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing caja-1.8.2-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1111/caja-1.8.2-2.fc20
then log in and leave karma (feedback).
Comment 28 Fedora Update System 2015-01-25 21:37:46 EST
caja-1.8.2-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 Fedora Update System 2015-02-03 07:00:25 EST
caja-1.8.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.