Bug 1114688

Summary: RFE: package systemd-journal-remote separately
Product: [Fedora] Fedora Reporter: Matthew Miller <mattdm>
Component: systemdAssignee: Zbigniew Jędrzejewski-Szmek <zbyszek>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: gholms, herrold, johannbg, lnykryn, msekleta, s, systemd-maint, vpavlin, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: systemd-215-2.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-05 17:31:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Matthew Miller 2014-06-30 16:15:09 UTC
This is similar to bug #908081. The systemd-journal-remote binary links against libmicrohttpd, which uses gnutls.

This isn't inherently bad (and is certainly better than a new httpd implementation or, worse, new crypto), but currently gnutls isn't required in minimal cloud images, and it's unfortunate introduce a new crypto library there, as it significantly increases the chance of needing to go through a security drill in updating the images.

Please subpackage systemd-journal-remote so this isn't necessary. (Possibly it could go in the *same* subpackage?) Thank you!

Comment 1 Zbigniew Jędrzejewski-Szmek 2014-06-30 16:56:24 UTC
Yes. I want to put gatewayd and the other utilities which use µhttpd and/or gnutls in one subpackage.