Bug 1118160

Summary: Various consistency issues and errors - New Host Group page
Product: Red Hat Satellite 6 Reporter: David O'Brien <daobrien>
Component: Host GroupAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED NEXTRELEASE QA Contact: Katello QA List <katello-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.0.3CC: bkearney, dcleal, mmurray, rohoover
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-11 15:45:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David O'Brien 2014-07-10 06:15:29 UTC
Description of problem:

I believe an initiative is under way to standardize and up the level of consistency in the UI. I'll add things that I find while updating the doc to this bug.

Version-Release number of selected component (if applicable):

6.0.3


Actual results:

Various instance of mixed or inconsistent case on GUI labels, buttons, and so on.

Expected results:


Additional info:

Will add more instances as I go through the doc.

Comment 1 RHEL Product and Program Management 2014-07-10 06:44:06 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-07-10 07:01:15 UTC
If you could file new bugs per issue or category, that'd be preferable as I can't triage this until we know what needs to be done.  Please also keep bugs public unless absolutely necessary.

Comment 4 David O'Brien 2014-07-11 00:40:59 UTC
Updated bz title to focus on "New Host Group" page in webUI.

On each of the tabs - Host Group, Puppet Classes, Network, etc., - there is a mixture of labels with title case (e.g., Content Source) and with sentence case (e.g., Content view). We should try to be consistent across all labels. I suggest title case as it aligns with what we do in doc, but I guess this is up to the UI team.

I'm also unsure of the outcome of "lifecycle" vs "life cycle". Technically it's two words but it's used in both forms in Satellite. Everywhere in doc it's two words unless it's actually a product name or some other proper noun.

We should also make sure mandatory fields are indicated. I think this has been recognized and is being addressed.

thanks

Comment 5 Dominic Cleal 2014-07-11 09:12:49 UTC
Ok, tentatively moving this to Katello for triage then as the examples you're giving (Content *, lifecycle) are all from that component.

Generally in fields and menus in Foreman I've tried to prefer sentence case, though tabs use title case.

http://projects.theforeman.org/issues/6400 tracks adding notes for mandatory fields, no BZ at the moment.

Comment 8 Roxanne Hoover 2016-11-11 15:34:51 UTC
Title case is the correct format. I believe the UX team has already gone through and made updates to the Foreman UI to title case.

Comment 9 Bryan Kearney 2016-11-11 15:45:00 UTC
Closing this out based on comment 8. If you are still seeing issues from 6.3 on, please feel free and re-open with specific instances.