Bug 1118804

Summary: umask argument in Upstart defaults should not use a different argument style
Product: [Retired] Pulp Reporter: Brian Bouterse <bmbouter>
Component: async/tasksAssignee: pulp-bugs
Status: CLOSED UPSTREAM QA Contact: pulp-qe-list
Severity: low Docs Contact:
Priority: medium    
Version: 2.4 BetaCC: cduryee, mhrivnak
Target Milestone: ---Keywords: Task, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-28 22:12:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Brian Bouterse 2014-07-11 14:45:42 UTC
Normally, spaces are used as the argument style for all celery service arguments. When a space was used as the argument name, value separator for the umask operator, the services would not start because of a parsing error in the init script for Upstart systems.

This bug should revert this commit[0], and adjust the init scripts for Upstart so they work with the space style argument.

[0]:  https://github.com/pulp/pulp/commit/5942340617afd61640b26a5eba125ebda8aede75

Comment 1 Brian Bouterse 2015-02-28 22:12:47 UTC
Moved to https://pulp.plan.io/issues/471