Bug 1118883

Summary: [RFE] generate uuid for vdsm.id on deployment
Product: [oVirt] ovirt-host-deploy Reporter: Joop van de Wege <jvandewege>
Component: Plugins.VDSMAssignee: Alon Bar-Lev <alonbl>
Status: CLOSED NOTABUG QA Contact: Pavel Stehlik <pstehlik>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 1.0.0CC: acathrow, alonbl, bazulay, bugs, dougsland, gklein, iheim, jvandewege, mgoldboi, yeylon
Target Milestone: ---Keywords: FutureFeature, SupportQuestion
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-28 04:55:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Joop van de Wege 2014-07-11 19:17:33 UTC
After some discussion on the ML this RFE request.
There are quite a few hardware vendors that don't fill in thee systems uuid which leads to vdsm not being installed during host deployment.
This problem can  be circumvented by using uuidgen instead of relying on dmidecode returning the uuid.

Comment 2 Alon Bar-Lev 2014-07-15 11:15:21 UTC
(In reply to Douglas Schilling Landgraf from comment #1)
> Ref.:
> http://lists.ovirt.org/pipermail/users/2014-July/025822.html
> http://lists.ovirt.org/pipermail/users/2014-July/025831.html

From the reference you created a duplicate of a system, but in order it to be unique you need to remove /etc/vdsm/vdsm.id and probably other system static identities, such as dhcp host id. Then redeploy the host.

If you like to move the mass storage device between hosts, you should also put a random uuid within /etc/vdsm/vdsm.id after each clone, this will enable the new host to be detached from its clone, regardless of the host it is being installed.

Comment 3 Joop van de Wege 2014-09-22 11:23:14 UTC
Hi Alon,

You closed the BZ but I still get email asking for more info.
Ah, see the checkbox below my typing so this should be the last time :-)

Joop