Bug 1118932

Summary: 3.15.x-200.fc20 causes lightdm to start with a black screen
Product: [Fedora] Fedora Reporter: Zirneklitis <k_a_r_l_o_>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 20CC: dowdle, gansalmon, hdegoede, itamar, jonathan, kernel-maint, madhu.chinakonda, mchehab
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-15 13:13:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
The list of running processes (from terminal login)
none
Output from lspci none

Description Zirneklitis 2014-07-12 02:50:30 UTC
Description of problem:

After updating kernel (3.15.3-200.fc20 or 3.15.4-200.fc20) the lightdm login screen is blank and black.

Switching to a text terminal ([Alt]_[Ctrl]_[F2]), waiting for several seconds and switching back to the graphical login screen ([Alt]_[Ctrl]_[F1]), makes the login screen to appear.

There was no such problems with previous versions of kernel (e.g. 3.14.9-200.fc20)



Version-Release number of selected component (if applicable):

kernel-3.15.3-200.fc20.x86_64; kernel-3.15.4-200.fc20.x86_64
lightdm-1.8.8-1.fc20.x86_64

How reproducible:

100%


Steps to Reproduce:

1. Start computer using kernel 3.15.4-200


Actual results:

Graphical login screen is black.


Expected results:

The Graphical login screen should be displayed.


Additional info:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)

Comment 1 Scott Dowdle 2014-07-18 21:42:54 UTC
I've run into this issue as well on my Dell Latitude D630 laptop.  How I get past it is I alt-control-F2 and then switch back to alt-control-F1 and the graphical login screen appears.

Comment 2 Scott Dowdle 2014-07-21 17:33:22 UTC
Just a note that this also can affect kdm as that's what I'm running on my laptop.  It is still an issue with the kernel-3.15.6-200.fc20.x86_64 that was recently released... although I'm not sure if this is a kernel-related issue or not.

Comment 3 Scott Dowdle 2014-08-12 16:34:54 UTC
There have been a number of package updates since my last comment... and I'm currently on the kernel-3.15.8-200.fc20.x86_64... and I can no longer duplicate the issue... so... so far as I know... it has been resolved and this bug can be closed as FIXED.  Does the original bug reporter concur?

Comment 4 Zirneklitis 2014-08-13 04:43:41 UTC
For my laptop the error is still there (kernel-3.15.8-200.fc20.x86_64) :-(

The list of running processes will be attached.

Comment 5 Zirneklitis 2014-08-13 04:50:36 UTC
Created attachment 926253 [details]
The list of running processes (from terminal login)

Switching back to graphical window with Alt_Ctrl_F1 does not help - the screen remains blank and dark (not black).

Comment 6 Zirneklitis 2014-08-20 05:08:16 UTC
For my laptop the error is still there (kernel-3.15.10-200.fc20.x86_64) :-(

More information:

If an external monitor is attached to my laptop _before_ the laptop is switched-on, the normal log-in screen appears. The laptop monitor is considered to be the primary (as expected).

If there is no external monitor - the blank screen again.

Comment 7 Zirneklitis 2014-08-20 05:11:43 UTC
Created attachment 928617 [details]
Output from lspci

Comment 8 Zirneklitis 2014-09-15 10:59:41 UTC
At last! The kernel-3.16.2-200.fc20.x86_64 behaves as expected :-)

N.B. During the last update the X.Org X11 X Window System xinit startup scripts was updated as well (xorg-x11-xinit-1.3.4-1.fc20).

This bug may be marked as CLOSED.