Bug 1119691

Summary: Live snapshot not working
Product: [Retired] oVirt Reporter: Raz Tamir <ratamir>
Component: vdsmAssignee: Daniel Erez <derez>
Status: CLOSED CURRENTRELEASE QA Contact: Raz Tamir <ratamir>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 3.5CC: acanan, amureini, bazulay, danken, derez, fromani, gklein, iheim, mgoldboi, ratamir, rbalakri, yeylon
Target Milestone: ---Keywords: AutomationBlocker, Regression
Target Release: 3.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: storage
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-10-17 12:30:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Storage RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1115126, 1190742    
Bug Blocks:    
Attachments:
Description Flags
vdsm and engine logs none

Description Raz Tamir 2014-07-15 10:01:53 UTC
Created attachment 918107 [details]
vdsm and engine logs

Description of problem:
Setup:
1 vm with 1 disk and OS.
I created a file, took live snapshot, and deleted the file.
After previewing the snapshot, I was expecting to see the file but it wasn't restored.

Version-Release number of selected component (if applicable):
vdsm-4.16.0-3.git601f786.el6.x86_64
libvirt-0.10.2-29.el6_5.9.x86_64
ovirt-engine-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Explained above
2.
3.

Actual results:
Live snapshot don't work


Expected results:
Live snapshot should work


Additional info:

Comment 1 Itamar Heim 2014-07-15 11:12:14 UTC
qemu-kvm-rhev installed?

Comment 2 Raz Tamir 2014-07-15 11:19:18 UTC
gpxe-roms-qemu-0.9.7-6.10.el6.noarch
qemu-img-0.12.1.2-2.415.el6_5.10.x86_64
qemu-kvm-0.12.1.2-2.415.el6_5.10.x86_64
qemu-kvm-tools-0.12.1.2-2.415.el6_5.10.x86_64

Comment 3 Daniel Erez 2014-07-15 17:28:07 UTC
According to the logs and test environment, there are a couple of issues here:
* Live snapshot creation fails on *block* storage domain - similar to bug 1115126 (already in modified). 
* qemu-kvm-rhev wasn't installed on the relevant host, hence, according to bug 1009100, the operation should have been blocked on canDo indicating that "Operation not supported by QEMU."

Thus:
* Adding bug 1115126 to 'Depends On' and moving to POST
* @Francesco - shouldn't live snapshot be disabled/blocked when qemu-kvm-rhev isn't installed (bug 1009100)?

Comment 4 Francesco Romani 2014-07-16 09:15:46 UTC
(In reply to Daniel Erez from comment #3)
> * @Francesco - shouldn't live snapshot be disabled/blocked when
> qemu-kvm-rhev isn't installed (bug 1009100)?

The current code doesn't do such check, instead relies on libvirt reporting *and* as default allows live snapshot for backward compatibility, since only
newer libvirts have this new reporting capability.

Comment 5 Daniel Erez 2014-07-16 09:34:23 UTC
(In reply to Francesco Romani from comment #4)
> (In reply to Daniel Erez from comment #3)
> > * @Francesco - shouldn't live snapshot be disabled/blocked when
> > qemu-kvm-rhev isn't installed (bug 1009100)?
> 
> The current code doesn't do such check, instead relies on libvirt reporting
> *and* as default allows live snapshot for backward compatibility, since only
> newer libvirts have this new reporting capability.

Shouldn't libvirt report that live snapshot is not supported when qemu-kvm-rhev isn't installed?

Comment 6 Francesco Romani 2014-07-16 11:26:21 UTC
(In reply to Daniel Erez from comment #5)
> (In reply to Francesco Romani from comment #4)
> > (In reply to Daniel Erez from comment #3)
> > > * @Francesco - shouldn't live snapshot be disabled/blocked when
> > > qemu-kvm-rhev isn't installed (bug 1009100)?
> > 
> > The current code doesn't do such check, instead relies on libvirt reporting
> > *and* as default allows live snapshot for backward compatibility, since only
> > newer libvirts have this new reporting capability.
> 
> Shouldn't libvirt report that live snapshot is not supported when
> qemu-kvm-rhev isn't installed?

Libvirt detects the support using the capabilities reported in turn by the underlying QEMU. This is safer than just checking the name.

Comment 7 Daniel Erez 2014-07-16 12:20:18 UTC
(In reply to Francesco Romani from comment #4)
> (In reply to Daniel Erez from comment #3)
> > * @Francesco - shouldn't live snapshot be disabled/blocked when
> > qemu-kvm-rhev isn't installed (bug 1009100)?
> 
> The current code doesn't do such check, instead relies on libvirt reporting
> *and* as default allows live snapshot for backward compatibility, since only
> newer libvirts have this new reporting capability.

As stated in comment #4, we don't have an alternative indication for live snapshot support either than what's reported by libvirt. Hence, the engine can't block the operation in such scenario - moving to MODIFIED as bug 1115126.

Comment 8 Raz Tamir 2014-08-11 07:45:51 UTC
Verified - ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

Comment 9 Sandro Bonazzola 2014-10-17 12:30:33 UTC
oVirt 3.5 has been released and should include the fix for this issue.