Bug 1119854

Summary: Productid not installed after newly installed RHEL6.6 server build
Product: Red Hat Enterprise Linux 6 Reporter: John Sefler <jsefler>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED WORKSFORME QA Contact: Release Test Team <release-test-team>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 6.6CC: alikins, borgan, ckozak, gxing
Target Milestone: beta   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-17 13:49:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1014343    

Description John Sefler 2014-07-15 16:26:54 UTC
Description of problem:
Bug 1104498 is also occurring on RHEL6.6...
It looks like comment https://bugzilla.redhat.com/show_bug.cgi?id=1104498#c11 is applicable on rhel6.6 too.

After a Minimal install of http://download.devel.redhat.com/nightly/RHEL-6.6-20140715.n.1/6/Server/x86_64/os/ there is no product cert 69.pem installed.

[root@RHEL-6 ~]# subscription-manager list --installed
No installed products to list
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Expected to see Product Id 69 RHEL Server installed.


Version-Release number of selected component (if applicable):
[root@RHEL-6 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.6 Beta (Santiago)
[root@RHEL-6 ~]# rpm -q subscription-manager
subscription-manager-1.12.4-1.el6.x86_64


How reproducible:


Steps to Reproduce:
1. Perform minimal installation of RHEL-6.6-20140715.n.1 Server (or any variant)
2. list the files in directory /etc/pki/product
3. subscription-manager list --installed


Actual results:
[root@RHEL-6 ~]# ls /etc/pki/product/
[root@RHEL-6 ~]# 


Expected results:
[root@RHEL-6 ~]# ls /etc/pki/product/
69.pem
[root@RHEL-6 ~]# 


Additional info:

Comment 1 John Sefler 2014-07-15 19:29:00 UTC
Moving this to component anaconda since I suspect it is caused by the same problem as Bug 1118206.

Comment 2 Adrian Likins 2014-07-17 13:39:31 UTC
Having replicated this, but I suspect it's not the same issue as 1118206. That
was related to some particular details of how RHEL5 installer images are built, and the RHEL6 image building is more robust about deps.

 http://download.devel.redhat.com/nightly/RHEL-6.6-20140715.n.1/6/Server/x86_64/os/repodata/

doesn't seem to have a product id in the repo data, so that's likely the cause.

Comment 3 Carter Kozak 2014-07-17 13:49:19 UTC
I just tried to reproduce with rhel6.6 alpha 1.1, and the product cert was created just fine.  python-dateutil is installed.  same subman as the test.

Works for me on a newer build.