Bug 1120208

Summary: configure logrotate for pacemaker
Product: Red Hat OpenStack Reporter: Leonid Natapov <lnatapov>
Component: openstack-foreman-installerAssignee: Jason Guiditta <jguiditt>
Status: CLOSED WONTFIX QA Contact: Leonid Natapov <lnatapov>
Severity: unspecified Docs Contact:
Priority: high    
Version: 5.0 (RHEL 7)CC: jguiditt, mburns, morazi, randy_perryman, rhos-maint, yeylon
Target Milestone: ---Keywords: ZStream
Target Release: Installer   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1211324 (view as bug list) Environment:
Last Closed: 2016-04-04 14:53:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1211324    

Description Leonid Natapov 2014-07-16 12:40:24 UTC
The log level and the retry interval on pacemaker should be turned down. The log growth and fills up the disk.

-rw-rw----. 1 hacluster haclient 4.8G Jul 16 08:01 pacemaker.log

I think it grew because the glance mount failed and it kept retrying to mount. So with correct params it shouldn't grow that fast.We probably shouldn't retry the mount N times per second, but maybe once per a few seconds. In any case we should rotate the log.

Comment 2 Mike Burns 2014-09-23 15:02:23 UTC
Should this logrotate be done on the pacemaker level or through puppet?

Comment 3 Jason Guiditta 2014-09-23 16:24:25 UTC
Even though the subject is logrotate, the description actually asks for setting logging level and retry interval for pacemaker, which sounds like something we should be able to set from quickstack.  However, after a quick look, I don't see anywhere that it can be set via puppet-pacemaker.  So, this would need to be added there, and then we could call it from quickstack easily enough.

Comment 4 Mike Burns 2014-09-24 18:55:14 UTC
Yes, the text asks for log level control, but even if we lowered the level, it would still grow in this case.  The log filled with glance mount errors.  Errors won't ever be rotated out.  

We should instead rotate the log file which will prevent the log from growing so big.

Comment 5 Mike Burns 2015-04-13 16:29:12 UTC
*** Bug 1211324 has been marked as a duplicate of this bug. ***

Comment 6 Jason Guiditta 2016-04-04 14:53:10 UTC
ofi is no longer implementing new features