Bug 1120322

Summary: [RFE]Enable copy-on-write clone of images in glance with RBD as backend
Product: Red Hat OpenStack Reporter: Chris Dearborn <christopher_dearborn>
Component: openstack-foreman-installerAssignee: Jason Guiditta <jguiditt>
Status: CLOSED DUPLICATE QA Contact: Ami Jeain <ajeain>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 5.0 (RHEL 6)CC: ajeain, arkady_kanevsky, jdonohue, mburns, morazi, rhos-maint, yeylon
Target Milestone: ---Keywords: FutureFeature, OtherQA
Target Release: Installer   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: sreichar@redhat.com; jdonohue@redhat.com; cdevine@redhat.com Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1120321 Environment:
Last Closed: 2014-09-23 15:07:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1120317    
Bug Blocks: 1108193    

Description Chris Dearborn 2014-07-16 18:07:41 UTC
+++ This bug was initially created as a clone of Bug #1120321 +++

Description of problem:
When Glance is configured to use rbd as a backend, Ceph requires show_image_direct_url to be set to True to allow copy-on-write clone of an image.
See: http://ceph.com/docs/next/rbd/rbd-openstack/

This bug is to modify astapor (controller_common.pp and glance.pp) so that if the glance backend is "rbd" , then it will pass True for show_image_direct.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Chris Dearborn on 2014-07-16 14:05:42 EDT ---

Taken from http://ceph.com/docs/next/rbd/rbd-openstack/:
Note that this exposes the back end location via Glance’s API, so the endpoint with this option enabled should not be publicly accessible

Comment 3 Mike Burns 2014-09-23 15:07:13 UTC

*** This bug has been marked as a duplicate of bug 1120321 ***