Bug 1120428

Summary: Rubygem-Staypuft: Deployment of nonHA neutron (Flat) gets stuck installing the networker.
Product: Red Hat OpenStack Reporter: Alexander Chuzhoy <sasha>
Component: openstack-puppet-modulesAssignee: Martin Magr <mmagr>
Status: CLOSED NOTABUG QA Contact: Alexander Chuzhoy <sasha>
Severity: unspecified Docs Contact:
Priority: urgent    
Version: 5.0 (RHEL 7)CC: aberezin, jguiditt, kambiz, mburns, morazi, sclewis, yeylon
Target Milestone: gaKeywords: Reopened
Target Release: 5.0 (RHEL 7)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-25 21:53:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
output from "ifconfig", "ovs-vsctl show" none

Description Alexander Chuzhoy 2014-07-16 22:27:28 UTC
Created attachment 918550 [details]
output from "ifconfig", "ovs-vsctl show"

Rubygem-Staypuft:  Deployment of nonHA neutron (Flat) gets stuck installing the networker.


Steps to reproduce:
1. Install rhel-osp-installer
2. Configure and run a nonHA Neutron deployment with Flat Tenant Network Type.

Result:
the deployment gets stuck (not paused, no errros shown) installing the networker 60%.
Further checking revealed that the networker isn't reachable - couldn't access the networker using SSH nor ping it.

Attaching the output from some commands - took from the console.

Expected result: successful deployment.

Comment 1 Alexander Chuzhoy 2014-07-16 22:28:13 UTC
Environment:
rhel-osp-installer-0.1.1-1.el6ost.noarch
openstack-foreman-installer-2.0.15-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-19.1.el6ost.noarch

Comment 2 Alexander Chuzhoy 2014-07-16 22:29:27 UTC
This was poodle 2014-07-16.3.

Comment 5 Jason Guiditta 2014-07-22 21:24:14 UTC

*** This bug has been marked as a duplicate of bug 1122142 ***

Comment 6 Alexander Chuzhoy 2014-07-22 21:59:17 UTC
This seems like a different issue. This one is for flat tenant network type. The other one is for GRE.

Comment 7 Alexander Chuzhoy 2014-07-22 22:01:38 UTC
The other one is for vxlan actually, where the deployment completes and then issues discovered running openstack network.

Comment 8 Alexander Chuzhoy 2014-07-22 22:09:04 UTC
Checked against puddle 2014-07-16.2

the deployment gets stuck on networker. Running the agent manually on the networker shows this:


Error: /Stage[main]/Neutron::Agents::Ovs/Neutron::Plugins::Ovs::Port[physnet-external:br-ex]/Vs_port[br-ex]: Could not evaluate: Execution of '/usr/bin/ovs-vsctl list-ports physnet-external' returned 1: ovs-vsctl: no bridge named physnet-external
Notice: /Stage[main]/Neutron::Agents::Ovs/Service[neutron-plugin-ovs-service]: Dependency Vs_port[br-ex] has failures: true
Warning: /Stage[main]/Neutron::Agents::Ovs/Service[neutron-plugin-ovs-service]: Skipping because of failed dependencies
Notice: Finished catalog run in 0.87 seconds

Comment 9 Alexander Chuzhoy 2014-07-23 18:00:52 UTC
Reproduced with with liveCD version rhelosp-installer-live-6.5-20140722.0.iso.
The networker was unable to reach any host (including contacting the puppet server).
Basically exactly the same issue as originally reported.

Comment 13 Mike Orazi 2014-07-25 20:34:16 UTC
If we can't reproduce on on multi-nic systems, this should be closed or deferred.

Comment 14 Mike Orazi 2014-07-25 21:53:28 UTC
Closing as notabug for now based on the single nic issue.