Bug 1120709

Summary: Virt-Manager can not change USB controller mode to 2.0
Product: [Community] Virtualization Tools Reporter: Neil How <neilhhw>
Component: virt-managerAssignee: Cole Robinson <crobinso>
Status: CLOSED WONTFIX QA Contact:
Severity: high Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: acathrow, berrange, crobinso, gscrivan
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-17 15:22:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
The capture of virt-manager none

Description Neil How 2014-07-17 14:07:48 UTC
Created attachment 918730 [details]
The capture of virt-manager

Description of problem:


Version-Release number of selected component (if applicable):
0.9.5

How reproducible:
Install virt-manager and install a Windows guest. When try to change USB controller mode into 2.0, no selection is available.
With a workaround in below field, I try to use virtsh to edit the guest configuration xml file as link below, it shows "XML error: Attempted double use of PCI slot 0000:00:07.0 (may need "multifunction='on'" for device on function 0)"
http://askubuntu.com/questions/192804/virt-manager-usb-2-0-problem


Steps to Reproduce:
1. Install a windows 7 guest with virt-manager
2. Change the USB controller mode
3. The mode can not be changed

Actual results:
The USB controller mode is always default, and can not change to USB2

Expected results:
The USB mode can be changed into USB2.0, and the other USB1.0 should work also.

Additional info:
N/A

Comment 1 Giuseppe Scrivano 2014-07-17 14:40:29 UTC
If I understand correctly, you cannot change the USB controller model via virt-manager.  virt-manager 1.0.1 allows to change the USB controller model.

Have you already tried a newer version of virt-manager?

Comment 2 Cole Robinson 2014-07-17 15:22:03 UTC
Yeah, the upstream bug tracker isn't for bugs against older versions of virt-manager. There has been a huge amount of change since 0.9.5, so either try the latest version, or file a bug against whatever distro is shipping 0.9.5

If the latest version still has this bug, please reopen