Bug 112085

Summary: httpd has not /etc/sysconfig/httpd as config file
Product: Red Hat Enterprise Linux 3 Reporter: Milan Kerslager <milan.kerslager>
Component: httpdAssignee: Joe Orton <jorton>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-16 17:01:40 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Milan Kerslager 2003-12-14 05:37:01 EST
The config file /etc/sysconfig/httpd is not included in httpd package
even /etc/init.d/httpd uses it. When looking for config files by rpm
-qc httpd it does not show this config file.

Because Apache show dates in auto-generated indexes in language given
by current locale when the server is started, this could be good to
mention this in an example of /etc/sysconfig/httpd like his:

$ cat /etc/sysconfig/httpd
# set your own environment for runnnig httpd daemon here

# uncomment next line to show dates in indexes in english
# instead of language given by system-wide locale
#LANG=C
Comment 1 Milan Kerslager 2004-09-05 02:11:54 EDT
RHEL3 U3 hasn't the file too.
Comment 2 Joe Orton 2004-09-06 08:20:11 EDT
Thanks for the report.

With respect to the $LANG setting, FYI: httpd is started with LANG=C
by default for FC3 onwards.   A sample /etc/sysconfig/httpd is also
now included as of httpd-2.0.50-6.

You would you like to see the example /etc/sysconfig/httpd included
for future RHEL3 updates?
Comment 3 Joe Orton 2004-11-16 17:01:40 EST
This is fixed for RHEL4.