Bug 1120897

Summary: Wrong package name on compreensive guide
Product: OKD Reporter: Ricardo Katz <ricardo.katz>
Component: DocumentationAssignee: Bilhar <baulakh>
Status: CLOSED CURRENTRELEASE QA Contact: Bilhar <baulakh>
Severity: high Docs Contact:
Priority: unspecified    
Version: 2.xCC: hripps, mmccomas
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-23 14:31:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ricardo Katz 2014-07-17 23:39:34 UTC
In this place: 'http://openshift.github.io/documentation/oo_deployment_guide_comprehensive.html#installation-2' the package name is mcollective-client when it should be ruby193-mcollective-client to use the right Openshift Origin deps and environment.

Comment 2 N. Harrison Ripps 2014-07-22 15:38:32 UTC
Bilhar--your pull request includes two commits from October 2013 that you don't want to include.

The easiest way to fix this:

1. Go back to the master branch:

    git checkout master

2. Make sure master is up-to-date:

    git fetch upstream && git rebase upstream/master && git push origin master

3. Create a new feature branch. Per convention, call it 'bug_<NUMBER>'

    git checkout -b bug_1120897

4. Now cherry-pick the relevant commit from your original branch to this new one:

    git cherry-pick 237dff48f3ad5b175a393b9ef710b4d1fd67caf3

5. Push the new feature branch to GitHub

    git push origin bug_1120897

6. Create a new pull request and close the old one.

This way the only change in the pull request will be the relevant one.

Cherry-picking works because each commit gets a unique ID, regardless of which branch it belongs to. So you are telling git: "wherever in my local repo you find this commit, add it to my current branch"

Please let me know when the new PR is ready for review.

Comment 4 N. Harrison Ripps 2014-07-23 14:31:38 UTC
PR is reviewed and merged:

https://github.com/openshift/origin-server/pull/5641

Thanks, Bilhar!