Bug 1121058

Summary: handling of dot files
Product: [Retired] Zanata Reporter: Akira TAGOH <tagoh>
Component: Component-zanata-client-ivyAssignee: zanata-dev-internal <zanata-dev-internal>
Status: CLOSED UPSTREAM QA Contact: Zanata-QA Mailling List <zanata-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: client-3.3CC: dchen, tagoh, zanata-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-07-29 02:39:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Akira TAGOH 2014-07-18 09:38:22 UTC
Description of problem:
the client reports what files are planning to be transferred on push though, if the target directory contains .pot say, it isn't included in the list but the operation simply failed like:
[INFO] pushing source doc [name= size=0] to server
[==   ][ERROR] Operation failed: Error status 405 Method Not Allowed returned

    To retry from the last document, please set the following option(s):

        --from-doc ""

.
[ERROR] Execution failed: Error status 405 Method Not Allowed returned

If kinda "no name" is wrong, the client should ignore a dot file.

Version-Release number of selected component (if applicable):
Client version: 3.1.1
Client timestamp: 20130829-0208
API version: 3.0.1
API timestamp: 20130827-0636

Comment 1 Ding-Yi Chen 2015-01-27 02:07:26 UTC
What's the use case that ".pot" (without basename) are valid?

Comment 2 Akira TAGOH 2015-01-27 04:20:57 UTC
that was just a mistake in a script but assuming no human error is also wrong. at least the above navigation confuses to recover.

Comment 3 Ding-Yi Chen 2015-01-27 08:18:43 UTC
I can see the argument that client should return ERROR and stop for invalid document name, so you know something wrong.

However, for big project like man-page-l10n, users might be frustrated to see it stop on 90% just because of this.

We will put a warning message like:
[WARNING] Invalid filename: <dir>/.pot

Comment 4 Akira TAGOH 2015-01-28 03:16:54 UTC
That sounds good to me. thanks

Comment 5 Zanata Migrator 2015-07-29 02:39:52 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-166