Bug 1121148

Summary: httpd-itk crashes
Product: [Fedora] Fedora EPEL Reporter: Robbie <robbie.bays>
Component: httpd-itkAssignee: Pavel Alexeev <pahan>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: pahan, s.adam
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-09-08 08:28:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Robbie 2014-07-18 13:43:27 UTC
Description of problem:
I have just installed httpd-itk from EPEL7 and fails to work with the default RHEL7 version of Apache 2.4.

Version-Release number of selected component (if applicable):
httpd-itk-2.2.22-9.el7.x86_64

How reproducible:
Every time I try to start httpd-itk.

Steps to Reproduce:
1. yum install httpd-itk
2. systemctl stop httpd.service
3. systemctl disable httpd.service
4. systemctl enable httpd-itk.service
5. systemctl start httpd-itk.service

Actual results:
httpd.itk: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf.modules.d/00-base.conf: Cannot load /etc/httpd/modules/mod_access_compat.so into server: /etc/httpd/modules/mod_access_compat.so: undefined symbol: ap_hook_check_access

Expected results:
For httpd-itk to start without crashing.

Additional info:
Am I right in thinking that the httpd-itk version supplied via the EPEL7 repo is intended for use with Apache 2.2 and not 2.4?

Comment 1 Stewart Adam 2014-08-23 18:42:14 UTC
I have the same issue as well. Problem is because el7 httpd is v2.4 and httpd-itk is v2.2, so many modules provided by httpd are not binary compatible.

Comment 2 Pavel Alexeev 2014-09-07 12:52:17 UTC
What version of httpd you have? Really I did not see any in epel7 branch.

Comment 3 Robbie 2014-09-08 07:43:01 UTC
(In reply to Pavel Alexeev (aka Pahan-Hubbitus) from comment #2)
> What version of httpd you have? Really I did not see any in epel7 branch.

The RHN supplies 2.4.6.  However this is too new a version for httpd-itk 2.2.22 to use, hence why httpd-itk fails to start correctly (EPEL needs to provide a 2.4 version for it to work).  http is a required dependency for httpd-itk:

[root@kmi-appsvr05 ~]# yum install httpd-itk
Loaded plugins: rhnplugin
This system is receiving updates from RHN Classic or Red Hat Satellite.
Resolving Dependencies
--> Running transaction check
---> Package httpd-itk.x86_64 0:2.2.22-9.el7 will be installed
--> Processing Dependency: httpd >= 2.2.22 for package: httpd-itk-2.2.22-9.el7.x86_64
--> Running transaction check
---> Package httpd.x86_64 0:2.4.6-18.el7_0 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package        Arch        Version             Repository                 Size
================================================================================
Installing:
 httpd-itk      x86_64      2.2.22-9.el7        epel                      141 k
Installing for dependencies:
 httpd          x86_64      2.4.6-18.el7_0      rhel-x86_64-server-7      1.2 M

Transaction Summary
================================================================================
Install  1 Package (+1 Dependent package)

Total size: 1.3 M
Total download size: 141 k
Installed size: 4.1 M
Is this ok [y/d/N]: N

Comment 4 Pavel Alexeev 2014-09-08 08:28:10 UTC
So it is a problem. Unfortunately MPM-ITK require at least httpd 2.4.7 (http://mpm-itk.sesse.net/).
There I also even did not found httpd component for reassign. Thus unfortunately I can't fix it.
I've could recommend you ask RedHat to update httpd and when (if) that happened I'll be glad build httpd-itk also.