Bug 1121201

Summary: spacewalk-repo-sync needs an arch filter capability
Product: Red Hat Satellite 5 Reporter: Chris Roberts <chrobert>
Component: Satellite SynchronizationAssignee: Michael Mráka <mmraka>
Status: CLOSED DEFERRED QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: low Docs Contact:
Priority: unspecified    
Version: 560CC: cperry
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-08 19:58:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 260381    

Description Chris Roberts 2014-07-18 15:50:29 UTC
I am unable to use spacewalk-repo-sync to populate a custom x86_64 Satellite channel with data from a mixed-architecture repo (specifically, oVirt 3.4 - http://resources.ovirt.org/pub/ovirt-3.4/rpm/el6/) because spacewalk-repo-sync has no way of masking out packages with an inappropriate architecture (ppc64 in my case). Consequently all the downloaded rpms remain orphaned because spacewalk-repo-sync fails to link any of them with the channel.  I have not been able to work around the problem using spacewalk-repo-sync's documented "-e" option (is this a regex?  how much of the file/path name is matched?).  I cannot synch arch-specific sub-repos (e.g. http://resources.ovirt.org/pub/ovirt-3.4/rpm/el6/x86_64/) because the subdirectories lack repodata.

Yum handles mixed-architecture repos of this sort just fine.  It seems to me that space-walk-repo-sync needs an option analogous to reposync's "-a" option, so that it can be instructed to ignore architectures that are not relevant to the channel, rather than just consistently failing.