Bug 1121232

Summary: RFE: make some install steps more robust
Product: OpenShift Container Platform Reporter: Luke Meyer <lmeyer>
Component: InstallerAssignee: Luke Meyer <lmeyer>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: unspecified    
Version: 2.1.0CC: bleanhar, jokerman, libra-bugs, libra-onpremise-devel, mmasters, mmccomas, yanpzhan
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-24 15:15:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Luke Meyer 2014-07-18 17:20:07 UTC
Description of problem:
We have a PR to address two issues to make the install a bit more robust in failure situations.
1. If anything goes wrong with yum, the install aborts immediately. The PR is to retry 3 times in case the failure is just something temporary.
2. If the rsync ssh key download fails, perhaps due to a timing issue, then the admin probably won't notice that it didn't work until they try to move a gear. The PR is to retry for 10 minutes.

Comment 1 Luke Meyer 2014-07-18 17:20:32 UTC
Please test https://github.com/openshift/openshift-extras/pull/397

Comment 3 Yanping Zhang 2014-07-21 12:18:35 UTC
There is a mistake in openshift.sh from https://github.com/openshift/openshift-extras/pull/397, so transfer the bug status to ASSIGNED.
Additional info:
In function install_rsync_pub_key(), the while loop isn't executed due to wrong syntax in "while [ `date +%s` < $END ];". 
I tested It should be "while [[ `date +%s` < $END ]]",then the loop can make sense.

Comment 4 Luke Meyer 2014-07-21 13:30:34 UTC
Thanks, sorry about that.

Comment 5 Miciah Dashiel Butler Masters 2014-07-21 13:33:31 UTC
Also, -lt is the correct operator to use here.

Comment 6 Luke Meyer 2014-07-23 16:56:36 UTC
PR updated, please re-try.