Bug 1121252

Summary: config revision not found when clicking on config file from system event history
Product: [Community] Spacewalk Reporter: Stephen Herr <sherr>
Component: WebUIAssignee: Stephen Herr <sherr>
Status: CLOSED CURRENTRELEASE QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 2.2   
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: spacewalk-java-2.2.122-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-21 13:12:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1207293    

Description Stephen Herr 2014-07-18 18:59:32 UTC
Description of problem:
Clicking on the config file like from the system event history leads to a "not found" page.

Version-Release number of selected component (if applicable):
spacewalk-java-2.2.121-1.fc19

How reproducible:


Steps to Reproduce:
1. Create a config file that has several revisions
2. Deploy it to a system, schedule and execute a config file comparison through the webui
3. Go to the server's event history and look at the event details. click on the config file name.

Actual results:
"We're sorry, but the configuration revision could not be found.", with the following message in catalina.out:
WARN  com.redhat.rhn.common.errors.LookupExceptionHandler - Could not find config revision with id=322

Expected results:
Should see the config file detils.

Additional info:
The problem is that we're inserting the config *file* id in the url when the argument is expection config *revision* id.

Comment 1 Stephen Herr 2014-07-18 19:01:53 UTC
Committing to Spacewalk master:
aaa085b547800f4fdef30dc5908a2d912025cf5a