Bug 1121381

Summary: dnf "installonlypkgs" default missing kernel-devel
Product: [Fedora] Fedora Reporter: Steve Bryant <stephenbryant>
Component: dnfAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: akozumpl, packaging-team-maint, pnemade, rholy, tla
Target Milestone: ---   
Target Release: ---   
Hardware: noarch   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-07-21 06:34:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Steve Bryant 2014-07-20 09:23:42 UTC
Description of problem:
In /usr/lib/python2.7/site-packages/dnf/const.py from dnf we have:
INSTALLONLYPKGS=('kernel',
                 'installonlypkg(kernel)',
                 'installonlypkg(kernel-module)',
                 'installonlypkg(vm)')

But in /usr/lib/python2.7/site-packages/yum/config.py from yum:
    installonlypkgs = ListOption(['kernel',
                                  'kernel-devel',
                                  'kernel-source',
                                  'installonlypkg(kernel)',
                                  'installonlypkg(kernel-module)',
                                  'installonlypkg(vm)'])

Version-Release number of selected component (if applicable):
dnf-0.5.4-1.fc20.noarch
(yum-3.4.3-152.fc20.noarch)

How reproducible:
By running "dnf upgrade" when there is a new kernel version available and "kernel-devel" is also installed.

Steps to Reproduce:
1.
2.
3.

Actual results:
Have up to three kernel packages installed, but only the "kernel-devel" package for the latest kernel.

Expected results:
Retain the corresponding "kernel-devel" package for each of the retained kernel packages.

Additional info:
The "kernel-devel" package "postinstall" script still runs trying to link identical files the new source tree with an existing source tree, but finds no match for every file as an upgrade, not an install has been done.

Comment 1 Ales Kozumplik 2014-07-21 06:34:45 UTC
Hello, this is a duplicate of bug 1062997, please see more details there.

*** This bug has been marked as a duplicate of bug 1062997 ***