Bug 1121691

Summary: blkid hangs when scanning multipath devices
Product: [Fedora] Fedora Reporter: Clay Haapala <chaapala>
Component: device-mapper-multipathAssignee: LVM and device-mapper development team <lvm-team>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 20CC: agk, bmarzins, dwysocha, fdinitto, heinzm, lvm-team, msnitzer, prajnoha, prockai
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-27 15:53:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Clay Haapala 2014-07-21 15:28:24 UTC
Description of problem:

My Fedora 20 workstation mounts several multipath devices via iscsi. Upon receiving the 3.15.3 and 3.15.4 kernel updates, the blkid utility hangs when scanning for partitions. Gparted then hangs in "scanning for devices". There is no iscsi traffic during this time. The load average starts to climb. Rebooting to 3.14.8-200.fc20.x86_64 finds all the partitions available as usual again.

A partition that is labeled is actually mounted, as in

$ ls /dev/disk/by-label/
cmlfed  System\x20Reserved
$ df
...
/dev/mapper/cmlfed1      314571776  29264224 283256992  10% /cml
$

but mounting by UUID label failed, probably because blkid did not return an values.

Version-Release number of selected component (if applicable):

Fedora 20, 3.15.3 and 3.15.4 kernels

How reproducible:

Every time, with the 3.15.{3,4} kernels

Steps to Reproduce:
1. Apply updates as of the availability of 3.15.4 kernel
2. Reboot
3. See high load average and 

Actual results:


Expected results:


Additional info:

Comment 1 Clay Haapala 2014-07-28 18:54:30 UTC
To clarify -- no iscsi traffic besides keep-alive "noop" messages, so the iscsi stack appears to be fine.

Comment 2 Clay Haapala 2014-08-27 15:53:57 UTC
Since filing this bug, I've been running with software updates as of the time of the 3.15.4 kernel, but booting 3.14.8 to keep my iscsi partitions usable.

Today, I applied all updates that the Software application offered (I didn't use yum, directly), and received a large number of updates including the 3.15.10 kernel. Allowed 3.15.10 to boot and:

My iscsi drives are back, and connecting/reading/writing without issue.

I apologize that I couldn't step through updates since 3.15.4 to see when it started working again -- the hardware has been dedicated to a project.

Closing the bug, as I can no longer reproduce.