Bug 1122154

Summary: xscorch won't start
Product: [Fedora] Fedora Reporter: Andreas Osowski <th0br0>
Component: xscorchAssignee: Gwyn Ciesla <gwync>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: gwync, samuel-rhbugs
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: xscorch-0.2.1-1.fc19 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-08-15 02:44:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 972351    
Bug Blocks:    

Description Andreas Osowski 2014-07-22 16:22:39 UTC
xscorch currently won't start, apparently due to API changes.

See the related Debian bug at https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=753516

Comment 1 Gwyn Ciesla 2014-07-29 13:18:24 UTC
Can't get a backtrace, glib2 bug. Setting as a blocker.

Comment 2 Samuel Sieb 2014-08-11 04:21:57 UTC
It doesn't look like it's crashing.  When run from the console, this is the output:

XScorch version 0.2.1-pre2
Copyright(c) 2000-2004 Justin David Smith
Copyright(c) 2000-2009 Jacob Luna Lundberg
Licensed under the GNU General Public License, version 2
See the Help menu for the license and a list of contributors.
/usr/share/xscorch//profiles.def: error: Malformed value for "tetRadius": 11 13

/usr/share/xscorch//profiles.def:9: error: Failed to add variable "tetRadius" to block "Standard"(7) (continuable error)
/usr/share/xscorch//profiles.def: error: Malformed value for "mob": t  true

/usr/share/xscorch//profiles.def:11: error: Failed to add variable "mob" to block "Standard"(7) (continuable error)
/usr/share/xscorch//profiles.def: error: Malformed value for "tetRadius": 11 13

/usr/share/xscorch//profiles.def:24: error: Failed to add variable "tetRadius" to block "DoubleTrack"(22) (continuable error)
/usr/share/xscorch//profiles.def: error: Malformed value for "efiency": 1  115

/usr/share/xscorch//profiles.def:26: error: Failed to add variable "efiency" to block "DoubleTrack"(22) (continuable error)
/usr/share/xscorch//profiles.def: error: Malformed value for "hness": 99 90

/usr/share/xscorch//profiles.def:27: error: Failed to add variable "hness" to block "DoubleTrack"(22) (continuable error)
/usr/share/xscorch//profiles.def: error: Malformed value for "mob": t  true

/usr/share/xscorch//profiles.def:28: error: Failed to add variable "mob" to block "DoubleTrack"(22) (continuable error)
/usr/share/xscorch//profiles.def: error: Malformed value for "tetRadius": 11 13

/usr/share/xscorch//profiles.def:41: error: Failed to add variable "tetRadius" to block "Fortification"(39) (continuable error)
/usr/share/xscorch//profiles.def: error: Malformed value for "haess": 1  125

/usr/share/xscorch//profiles.def:43: error: Failed to add variable "haess" to block "Fortification"(39) (continuable error)
/usr/share/xscorch//profiles.def: error: Malformed value for "mobi":  falsese

/usr/share/xscorch//profiles.def:44: error: Failed to add variable "mobi" to block "Fortification"(39) (continuable error)
/usr/share/xscorch//profiles.def: warning: "__null" isn't a valid class in this context, for variable "Standard".
/usr/share/xscorch//profiles.def: warning: "__null" isn't a valid class in this context, for variable "DoubleTrack".
/usr/share/xscorch//profiles.def: warning: "__null" isn't a valid class in this context, for variable "Fortification".
config_new: failed to build tanks_profile, or no tanks in def file.

Comment 3 Samuel Sieb 2014-08-11 04:25:58 UTC
Looks like the Debian report has the problem and a solution.  It looks like it is patched upstream although it looks like they're using a patch on their current package.

Comment 4 Gwyn Ciesla 2014-08-11 19:28:31 UTC
Thanks for the heads up, I'll get this out ASAP.

Comment 5 Fedora Update System 2014-08-11 19:29:26 UTC
xscorch-0.2.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xscorch-0.2.1-1.fc19

Comment 6 Fedora Update System 2014-08-11 19:29:33 UTC
xscorch-0.2.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xscorch-0.2.1-1.fc20

Comment 7 Fedora Update System 2014-08-15 02:44:50 UTC
xscorch-0.2.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-08-23 01:55:20 UTC
xscorch-0.2.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.