Bug 1122464

Summary: AJAX requests not killed before submitting new ones
Product: [Community] Beaker Reporter: Alexander Todorov <atodorov>
Component: web UIAssignee: matt jia <mjia>
Status: CLOSED CURRENTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 0.17CC: aigao, asaha, dcallagh, dowang, mjia
Target Milestone: 20.0Keywords: Patch
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-20 02:22:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1014438    
Bug Blocks:    
Attachments:
Description Flags
screenshot none

Description Alexander Todorov 2014-07-23 10:27:43 UTC
Created attachment 920194 [details]
screenshot

Description of problem:

On the Tasks tab of the system view there is a Query button. When clicked it will make an AJAX request and display a loading gif icon. When the button is clicked multiple times it will show multiple icons as well (see screenshot). 

As it seems the previous AJAX request is not killed and a new one is scheduled on the second and third clicks.

Comment 2 Nick Coghlan 2014-07-24 00:18:37 UTC
Dan, I know the system page redesign changes quite a bit about how the system page deals with AJAX requests. How does it affect this?

Comment 3 Dan Callaghan 2014-07-24 00:28:38 UTC
The Executed Tasks widget is not tackled in new-system-page. It would be the next thing on my hit list to be replaced with Backgrid though, since the current implementation is pretty terrible.

Comment 4 Nick Coghlan 2014-07-24 03:52:45 UTC
OK, this can go on the todo list for some time after we've migrated to the new system page design.

Comment 5 matt jia 2014-12-16 06:04:46 UTC
On gerrit: 

http://gerrit.beaker-project.org/#/c/3875/

Cheers, Matt Jia

Comment 6 matt jia 2015-01-07 05:27:11 UTC
(In reply to matt jia from comment #5)
> On gerrit: 
> 
> http://gerrit.beaker-project.org/#/c/3875/
> 
> Cheers, Matt Jia
I made a mistake on copy&paste the patch url and change it back to ASSIGNED since I am still working on it. Sorry about the confusion.

Cheers, Matt Jia

Comment 7 matt jia 2015-01-13 07:10:14 UTC
On Gerrit:

 http://gerrit.beaker-project.org/#/c/3926/

Cheers, Matt Jia

Comment 8 matt jia 2015-02-03 00:05:00 UTC
Verify Steps:

1. select any system from Systems page

2. go to Execute Tasks tab and check whether all the info are displayed properly, links are linked right places and functionalities such as sorting, filtering, query builder on the new UI.

Cheers, Matt Jia

Comment 11 Dan Callaghan 2015-04-20 02:22:41 UTC
Beaker 20.0 has been released.