Bug 1122871

Summary: [Hyper-V][REHL 7.0] Wrong IP injection when bridge ethernet
Product: Red Hat Enterprise Linux 7 Reporter: dnie <dnie>
Component: hyperv-daemonsAssignee: Vitaly Kuznetsov <vkuznets>
Status: CLOSED CANTFIX QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: jasowang, jingli, knoel, kys, leiwang, shwang, thozza, virt-bugs, vyasevic, yacao
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1122865 Environment:
Last Closed: 2015-03-26 16:17:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1122865    
Bug Blocks:    

Description dnie 2014-07-24 09:20:21 UTC
I check this issue in RHEL7.0 release version and the newest hypervkvpd also have the issue, so clone it.

hyperkvpd-version:
hypervkvpd-0-0.18.20130826git.el7.x86_64

+++ This bug was initially created as a clone of Bug #1122865 +++

Description of problem:
Execute kvp-ip-injection.ps1, The IP inject in Ethernet not bridge network
The script will change ethernet (Such as eht1) to static IP, not it's bridge network adapter
# ip addr
...
2: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:15:5d:6a:49:1a brd ff:ff:ff:ff:ff:ff
    inet 10.200.48.155/22 brd 10.200.51.255 scope global eth1
    inet6 fe80::215:5dff:fe6a:491a/64 scope link
       valid_lft forever preferred_lft forever
3: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 00:15:5d:6a:49:1a brd ff:ff:ff:ff:ff:ff
    inet 10.66.109.142/21 brd 10.66.111.255 scope global br0
    inet6 fe80::215:5dff:fe6a:491a/64 scope link
       valid_lft forever preferred_lft forever
...
# brctl show
bridge name        bridge id                STP enabled        interfaces
br0                8000.00155d6a491a        no                eth1
virbr0                8000.5254000d723b        yes                virbr0-nic


Version-Release number of selected component (if applicable):
Host: Hyper-V Server 2012 R2
kernel version:
2.6.32-491.el6
hypervkvpd-0-0.15.20130826git.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Login RHEL and Bridge Ethernet (such as eth0)
2. Install and start hypervkvpd
3. Execute kvp-ip-injection.ps1 in Host


Actual Result:
IP inject Ethernet eth0 not br0

Expected Result:
The IP injection should change br0 IP if guest have bridge network but it's bond ethernet adpater


Additional info:

--- Additional comment from dnie on 2014-07-24 05:02:59 EDT ---

IP injection scripts

--- Additional comment from RHEL Product and Program Management on 2014-07-24 05:11:36 EDT ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 1 Vitaly Kuznetsov 2014-10-29 16:23:52 UTC
I don't think we're seeing a bug here (or at least not a bug we can easily fix). It is rather a design issue with hyperv-kvpd. Hyper-V host has no idea about complex network configuration you have in your guest. It can be really complex in case you use bridging, bonding, ... hyperv-kvpd uses MAC address of a network card as an identifier when communicates with guest (both 'get' and 'set' requests) so it will always be changing real network adapter's address no matter what you've stacked on top.

I don't see an easy way to change anything here. Right now only simple configurations (network card with 1 static or dhcp address) are supported.

Comment 3 Shengnan Wang 2015-03-16 03:34:32 UTC
(In reply to Vitaly Kuznetsov from comment #1)
> I don't think we're seeing a bug here (or at least not a bug we can easily
> fix). It is rather a design issue with hyperv-kvpd. Hyper-V host has no idea
> about complex network configuration you have in your guest. It can be really
> complex in case you use bridging, bonding, ... hyperv-kvpd uses MAC address
> of a network card as an identifier when communicates with guest (both 'get'
> and 'set' requests) so it will always be changing real network adapter's
> address no matter what you've stacked on top.
> 
> I don't see an easy way to change anything here. Right now only simple
> configurations (network card with 1 static or dhcp address) are supported.

Hi Vitaly,

Since it is host design issue, could we close the bug as cantfix/wontfix?
Could i know your opinion?

Comment 4 Vitaly Kuznetsov 2015-03-26 16:17:25 UTC
(In reply to Shengnan Wang from comment #3)
> 
> Hi Vitaly,
> 
> Since it is host design issue, could we close the bug as cantfix/wontfix?
> Could i know your opinion?

Yes, we can't fix that.