Bug 1123327

Summary: Make CONFIG_LOG_BUF_SHIFT bigger on arm64
Product: [Fedora] Fedora Reporter: Richard W.M. Jones <rjones>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: ddutile, gansalmon, itamar, jonathan, kernel-maint, kmcmartin, madhu.chinakonda, mchehab
Target Milestone: ---Flags: rjones: needinfo? (kernel-maint)
Target Release: ---   
Hardware: aarch64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-10-21 18:58:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Richard W.M. Jones 2014-07-25 10:21:31 UTC
Description of problem:

On x86-64:
CONFIG_LOG_BUF_SHIFT=18

On ARM64:
CONFIG_LOG_BUF_SHIFT=14

This is annoying because messages scroll off the log buffer
very easily :-(

ARM64 machines have plenty of memory, so there seems no reason
why we shouldn't have a larger log buffer.

The patch is trivial:

diff --git a/config-arm64 b/config-arm64
index be0c3cb..b7e7bf1 100644
--- a/config-arm64
+++ b/config-arm64
@@ -45,7 +45,7 @@ CONFIG_HZ=100
 
 CONFIG_KVM=y
 CONFIG_KVM_ARM_MAX_VCPUS=8
-CONFIG_LOG_BUF_SHIFT=14
+CONFIG_LOG_BUF_SHIFT=18
 
 CONFIG_NFS_ACL_SUPPORT=y
 CONFIG_NFS_COMMON=y

Version-Release number of selected component (if applicable):

kernel-3.16.0-0.rc6.git1.1.fc22

Comment 1 Richard W.M. Jones 2014-07-25 10:22:43 UTC
Actually I think the patch is to remove that line completely
so it inherits from config-generic.

Comment 2 Josh Boyer 2014-07-25 12:05:20 UTC
(In reply to Richard W.M. Jones from comment #1)
> Actually I think the patch is to remove that line completely
> so it inherits from config-generic.

Right.  Adding the ARM guys on CC to weigh in.

Comment 4 Richard W.M. Jones 2014-10-21 10:12:03 UTC
This is a -1 line patch.  What can I do to get this actioned?  Can
I just push the fix myself?

diff --git a/config-arm64 b/config-arm64
index 29a2436..bdcc9b9 100644
--- a/config-arm64
+++ b/config-arm64
@@ -42,7 +42,6 @@ CONFIG_HZ=100
 
 CONFIG_KVM=y
 CONFIG_KVM_ARM_MAX_VCPUS=8
-CONFIG_LOG_BUF_SHIFT=14
 
 CONFIG_NFS_ACL_SUPPORT=y
 CONFIG_NFS_COMMON=y

Comment 5 Josh Boyer 2014-10-21 12:23:28 UTC
I'll change it in today's rawhide build.