Bug 1123355

Summary: Document -drive rerror/werror restrictions
Product: Red Hat Enterprise Linux 7 Reporter: Markus Armbruster <armbru>
Component: qemu-kvmAssignee: Markus Armbruster <armbru>
Status: CLOSED DEFERRED QA Contact: CongLi <coli>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.0CC: chayang, coli, hhuang, juzhang, michen, virt-maint
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1179995 (view as bug list) Environment:
Last Closed: 2019-02-06 22:59:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1179995    

Description Markus Armbruster 2014-07-25 12:14:25 UTC
Description of problem:
rerror/werror require support in the underlying device model.
Currently, only ide-hd, ide-cd, ide-drive (legacy), scsi-hd, scsi-cd,
scsi-disk (legacy), scsi-block (partially[*]), virtio-blk-device do.

Device models that do not support it: isa-fdc, cfi.pflash01,
scsi-generic, nvme, ...

How reproducible:
Always

Steps to Reproduce:
1. Peruse -help, qemu.1 and qemu-doc.html on rerror/werror.

Actual results:
Not a word on rerror/werror working only with some device models.

Expected results:
Restrictions get explained adequately along with the possible values
of rerror/werror.

Additional info:
Upstream first.

[*] Should work as long as you stick to plain read/write.  Fancy stuff
like write same gets tricky.

Comment 5 Ademar Reis 2017-11-28 17:13:29 UTC
> Component: qemu-kvm → qemu-kvm-rhev

Revert, we already have Bug 1179995 (sorry).

Comment 6 Ademar Reis 2019-02-06 22:59:18 UTC
WONTFIX in qemu-kvm due to capacity. We don't support direct invocation of qemu-kvm in RHEL anyway.