Bug 1123391

Summary: [RFE] support 240 vCPUs per hypervisor
Product: Red Hat Enterprise Virtualization Manager Reporter: Michal Skrivanek <michal.skrivanek>
Component: ovirt-engineAssignee: Martin Betak <mbetak>
Status: CLOSED ERRATA QA Contact: Artyom <alukiano>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.5.0CC: bgraveno, dfediuck, gklein, iheim, istein, lpeer, michal.skrivanek, rbalakri, Rhev-m-bugs, sherold, yeylon, ykaul
Target Milestone: ovirt-3.6.0-rcKeywords: FutureFeature, Triaged
Target Release: 3.6.0Flags: sherold: Triaged+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ovirt-3-6-0-2 Doc Type: Enhancement
Doc Text:
Red Hat Enterprise Virtualization supports virtual machines with up to 240 vCPUs. The previous version supported a maximum of 160 vCPUs.
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-03-09 20:35:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 864242, 1182450    
Bug Blocks: 1303474    

Description Michal Skrivanek 2014-07-25 13:41:53 UTC
RHEL 6.6+ hypervisor supports 240 vCPUS, let's take advantage of that!

Comment 1 Scott Herold 2014-07-25 13:43:41 UTC
Getting RHEV capability for "free".  Minimal testing required to determine that 240 vCPUs can be assigned to a VM.

Comment 2 Michal Skrivanek 2014-08-04 13:05:57 UTC
RHEL6.6 max vCPU has been increased to 240. This is tracked by BZ 864242 (Status = ON_QA).
RHEL7.1 max vCPU will be  increased to 240. This is tracked by BZ 1061403 (Status = NEW).

Comment 3 Michal Skrivanek 2014-08-04 13:12:23 UTC
have to exclude 7.0... probably increase to 240 on the engine side in 3.5 cluster compatibility and add an exception on RHEL 7 hosts scheduling

Comment 4 Michal Skrivanek 2014-08-04 13:16:07 UTC
where would be the bext place to filter out 7.0 hosts for >160 vCPUs?

Comment 7 Artyom 2015-09-06 12:32:15 UTC
Verified on rhevm-3.6.0-0.12.master.el6.noarch
According to polarion run:
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/testrun?id=3%5F6%5FVIRT%5FSupport%5F240%5FVCPUs%5FPer%5FVm%5Frun

Comment 9 errata-xmlrpc 2016-03-09 20:35:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html