Bug 1123635

Summary: Nautilus does not start in Gnome Classic.
Product: [Fedora] Fedora Reporter: Flóki Pálsson <flokip>
Component: nautilusAssignee: Matthias Clasen <mclasen>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: ccecchi, dennyvatwork, kalevlember, mclasen, spowd, ssuehle
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: nautilus-3.14.2-1.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-11-27 19:28:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043131    

Description Flóki Pálsson 2014-07-27 11:57:47 UTC
Description of problem:
Nautilus does not start in Gnome Classic.

Version-Release number of selected component (if applicable):
nautilus-3.13.2-2.fc21.x86_64


How reproducible:
always

Steps to Reproduce:
1.  Log in using Gnome Glassic
2.  Applications -> Favorits -> Files
3.

Actual results:
Nothing


Expected results:
Nautilus starts.

Additional info:
Also when starting from terminal.

floki@F21bt ~]$  nautilus
[floki@F21bt ~]$ 

Nautilus dos not start.

In Gnome 
then
floki@F21bt ~]$ nautilus 

(nautilus:17980): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

(nautilus:17980): GLib-GObject-WARNING **: The property GtkMisc:xalign is deprecated and shouldn't be used anymore. It will be removed in a future version.

(nautilus:17980): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

(nautilus:17980): GLib-GObject-WARNING **: The property GtkWidget:margin-left is deprecated and shouldn't be used anymore. It will be removed in a future version.

(nautilus:17980): GLib-GObject-WARNING **: The property GtkWidget:margin-right is deprecated and shouldn't be used anymore. It will be removed in a future version.

and Nautilus starts.

Comment 1 Greg` 2014-10-18 05:09:29 UTC
i get this very same Bug in Gnome Classic 3.14.1

Comment 2 Fedora Update System 2014-11-13 07:47:39 UTC
nautilus-3.14.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/nautilus-3.14.1-1.fc21

Comment 3 Fedora Update System 2014-11-14 12:10:00 UTC
Package nautilus-3.14.1-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nautilus-3.14.1-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15064/nautilus-3.14.1-1.fc21
then log in and leave karma (feedback).

Comment 4 Greg` 2014-11-14 23:58:57 UTC
still doesnt load. only way to open Naut up an thats by going to PLACES > COMPUTER

Comment 5 Fedora Update System 2014-11-16 14:45:39 UTC
nautilus-3.14.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Flóki Pálsson 2014-11-19 20:24:53 UTC
Does not work
nautilus-3.14.1-1.fc21.x86_64

Comment 7 Daniele Viganò 2014-11-21 16:59:41 UTC
I confirm, nautilus-3.14.1-1.fc21.x86_64 does not work in Gnome classic.

Even from terminal:

$ nautilus   # doesn't do anything
$ nautilus ~ # works
$ nautilus . # works
...

It works in gnome shell because there's no nautilus process already running (in classic mode it manages the desktop).

Comment 8 Kalev Lember 2014-11-26 16:35:04 UTC
Reopening since this didn't get fully fixed with 3.14.1.

Comment 9 Fedora Update System 2014-11-26 16:35:55 UTC
nautilus-3.14.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/nautilus-3.14.2-1.fc21

Comment 10 Kalev Lember 2014-11-26 16:38:00 UTC
Proposing as a F21 Freeze Exception. Workstation ships the GNOME Classic session in the default install and it would be nice if we could ship a fixed Nautilus on the install media.

Comment 11 Scott Suehle 2014-11-26 20:16:40 UTC
Discussed at today's blocker review meeting [1]. Accepted as a AcceptedFreezeException. As GNOME Classic ships with all workstation installs it would be great to get a fix in for this.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-12/

Comment 12 Fedora Update System 2014-11-27 19:28:44 UTC
nautilus-3.14.2-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.