Bug 1123981

Summary: With the new "rusle" table in ibus-table-cyrillic, typing '%' shows ':' in preëdit instead of committing it directly
Product: [Fedora] Fedora Reporter: Mike FABIAN <mfabian>
Component: ibus-tableAssignee: Mike FABIAN <mfabian>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: dchen, i18n-bugs, kent.neo, me, mfabian, pwu, shawn.p.huang, stsp2
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ibus-table-1.8.6-1.fc19 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1128912 (view as bug list) Environment:
Last Closed: 2014-08-08 08:39:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike FABIAN 2014-07-28 19:01:15 UTC
ibus-table-1.8.4
ibus-table-cyrillic-1.3.2

- Choose the "rusle" input method
- Type a %, one sees : in preëdit. It should be committed directly.


From the rusle.txt table:

### Begin Table data.
BEGIN_TABLE
@	"	0
$	;	0
%	:	0
^	,	0
&	.	0
...

Only % causes this problem, all the other characters are OK.

Comment 1 Mike FABIAN 2014-07-28 19:02:18 UTC
The reason is that % is interpreted as a wildcard in the sqlite
"SELECT ... LIKE ..." statement.

Comment 2 Fedora Update System 2014-07-29 11:15:59 UTC
ibus-table-1.8.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-table-1.8.6-1.fc19

Comment 3 Fedora Update System 2014-07-29 11:16:31 UTC
ibus-table-1.8.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-table-1.8.6-1.fc20

Comment 4 Fedora Update System 2014-07-30 06:59:26 UTC
Package ibus-table-1.8.6-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-table-1.8.6-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8986/ibus-table-1.8.6-1.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-08-08 08:39:42 UTC
ibus-table-1.8.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2014-08-08 08:42:04 UTC
ibus-table-1.8.6-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.