Bug 1124119

Summary: usb 3.0 HDD SCSI UASP
Product: [Fedora] Fedora Reporter: Ronio <kunronio>
Component: kernelAssignee: Hans de Goede <hdegoede>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 21CC: daveiro, gansalmon, gerien, hdegoede, itamar, jonathan, kernel-maint, kunronio, madhu.chinakonda, mchehab, mszpak, novyjindrich, rhbugs, rth, simon.panay
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-3.18.3-201.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-26 02:30:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
this is enclosure HDD 3.5"
none
system log messages
none
lspci -nn output
none
lsusb output
none
dmesg output with new kernel
none
dmesg output with kernel command: usb-storage.quirks=059b:0070:u none

Description Ronio 2014-07-29 02:31:22 UTC
Created attachment 922006 [details]
this is enclosure HDD 3.5"

Description of problem:
After buy Rock External HDD 3,5" UASP usb 3.0 enclosure + WD Caviar Black 1 TB (WD1003FZEX), i format in Windows 8 64bit with MBR--NTFS partition. In Windows it's not problem, working as it should & fast :-).
But when i connect in notebook Asus A53S usb3.0 Fedora 20 64bit problem arise & my notebook always crash/Hang :-(. in usb 2.0 port can't detect/ HDD can't fungtion 

Version-Release number of selected component (if applicable):
#uname -r
3.15.6-200.fc20.x86_64

# tail -20 /var/log/messages
Jul 29 08:29:13 localhost kernel: [   71.914208] sd 6:0:0:0: uas_eh_device_reset_handler
Jul 29 08:29:13 localhost kernel: [   71.914211] scsi host6: uas_eh_task_mgmt: LOGICAL UNIT RESET: error already running a task
Jul 29 08:29:13 localhost kernel: [   71.914216] scsi host6: uas_eh_bus_reset_handler start
Jul 29 08:29:13 localhost kernel: [   71.914320] usb 4-1: stat urb: killed, stream 32
Jul 29 08:29:13 localhost kernel: [   71.914445] usb 4-1: stat urb: killed, stream 3
Jul 29 08:29:13 localhost kernel: [   71.914567] usb 4-1: stat urb: killed, stream 2
Jul 29 08:29:13 localhost kernel: [   71.914691] sd 6:0:0:0: [sdb] uas_data_cmplt ffff8800372a4c00 tag 1, inflight: CMD abort
Jul 29 08:29:13 localhost kernel: [   71.914694] sd 6:0:0:0: [sdb] data cmplt err -2 stream 3
Jul 29 08:29:13 localhost kernel: [   71.914815] sd 6:0:0:0: [sdb] uas_data_cmplt ffff8800372a5500 tag 0, inflight: CMD abort
Jul 29 08:29:13 localhost kernel: [   71.914818] sd 6:0:0:0: [sdb] data cmplt err -2 stream 2
Jul 29 08:29:13 localhost kernel: [   71.914830] sd 6:0:0:0: [sdb] uas_zap_dead ffff8800372a5500 tag 0, inflight: CMD abort
Jul 29 08:29:13 localhost kernel: [   71.914833] sd 6:0:0:0: [sdb] abort completed
Jul 29 08:29:13 localhost kernel: [   71.914836] sd 6:0:0:0: [sdb] uas_zap_dead ffff8800372a4c00 tag 1, inflight: CMD abort
Jul 29 08:29:13 localhost kernel: [   71.914839] sd 6:0:0:0: [sdb] abort completed
Jul 29 08:29:13 localhost kernel: [   72.022313] usb 4-1: reset SuperSpeed USB device number 2 using xhci_hcd
Jul 29 08:29:13 localhost kernel: [   72.037011] xhci_hcd 0000:04:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880070556e00
Jul 29 08:29:13 localhost kernel: [   72.037016] xhci_hcd 0000:04:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880070556e48
Jul 29 08:29:13 localhost kernel: [   72.037020] xhci_hcd 0000:04:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880070556e90
Jul 29 08:29:13 localhost kernel: [   72.037023] xhci_hcd 0000:04:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880070556ed8
Jul 29 08:29:13 localhost kernel: [   72.041335] scsi host6: uas_eh_bus_reset_handler success

# tail -20 /var/log/messages

Jul 29 08:29:13 localhost kernel: [   71.914208] sd 6:0:0:0: uas_eh_device_reset_handler
Jul 29 08:29:13 localhost kernel: [   71.914211] scsi host6: uas_eh_task_mgmt: LOGICAL UNIT RESET: error already running a task
Jul 29 08:29:13 localhost kernel: [   71.914216] scsi host6: uas_eh_bus_reset_handler start
Jul 29 08:29:13 localhost kernel: [   71.914320] usb 4-1: stat urb: killed, stream 32
Jul 29 08:29:13 localhost kernel: [   71.914445] usb 4-1: stat urb: killed, stream 3
Jul 29 08:29:13 localhost kernel: [   71.914567] usb 4-1: stat urb: killed, stream 2
Jul 29 08:29:13 localhost kernel: [   71.914691] sd 6:0:0:0: [sdb] uas_data_cmplt ffff8800372a4c00 tag 1, inflight: CMD abort
Jul 29 08:29:13 localhost kernel: [   71.914694] sd 6:0:0:0: [sdb] data cmplt err -2 stream 3
Jul 29 08:29:13 localhost kernel: [   71.914815] sd 6:0:0:0: [sdb] uas_data_cmplt ffff8800372a5500 tag 0, inflight: CMD abort
Jul 29 08:29:13 localhost kernel: [   71.914818] sd 6:0:0:0: [sdb] data cmplt err -2 stream 2
Jul 29 08:29:13 localhost kernel: [   71.914830] sd 6:0:0:0: [sdb] uas_zap_dead ffff8800372a5500 tag 0, inflight: CMD abort
Jul 29 08:29:13 localhost kernel: [   71.914833] sd 6:0:0:0: [sdb] abort completed
Jul 29 08:29:13 localhost kernel: [   71.914836] sd 6:0:0:0: [sdb] uas_zap_dead ffff8800372a4c00 tag 1, inflight: CMD abort
Jul 29 08:29:13 localhost kernel: [   71.914839] sd 6:0:0:0: [sdb] abort completed
Jul 29 08:29:13 localhost kernel: [   72.022313] usb 4-1: reset SuperSpeed USB device number 2 using xhci_hcd
Jul 29 08:29:13 localhost kernel: [   72.037011] xhci_hcd 0000:04:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880070556e00
Jul 29 08:29:13 localhost kernel: [   72.037016] xhci_hcd 0000:04:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880070556e48
Jul 29 08:29:13 localhost kernel: [   72.037020] xhci_hcd 0000:04:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880070556e90
Jul 29 08:29:13 localhost kernel: [   72.037023] xhci_hcd 0000:04:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880070556ed8
Jul 29 08:29:13 localhost kernel: [   72.041335] scsi host6: uas_eh_bus_reset_handler success


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Hans de Goede 2014-07-29 08:23:46 UTC
Can you please provide the output of the following commands:

lspci -nn
lsusb

And can you also please do:

"dmesg > dmesg.log" directly after attaching the external hdd, so that dmesg.log includes all messages from the moment the kernel detects the usb device, including device and manufacturer strings, but also the very first error which happens, and then attach dmesg.log here ?

Comment 2 David 2014-08-02 23:45:26 UTC
Hi, having a similar problem myself also. I will attach just next all messages in system log since attaching my external USB 3.0 HDD, trying to copy a file to the drive, and then unmounting the drive in a forceful way. I will also attach the output of lspci and lsusb.

Comment 3 David 2014-08-02 23:48:36 UTC
Created attachment 923534 [details]
system log messages

Aug 03 00:32:03 - Just after I attached the drive
Aug 03 00:32:43 - When I try to copy a 4GB file to the drive and the copy freezes with nothing copied and I cannot access anymore the drive
Aug 03 00:33:11 - When I force unmount through Nautilus

Comment 4 David 2014-08-02 23:51:29 UTC
Created attachment 923535 [details]
lspci -nn output

Comment 5 David 2014-08-02 23:52:24 UTC
Created attachment 923536 [details]
lsusb output

Comment 6 David 2014-08-02 23:55:02 UTC
PS: this external hard drive works just fine in Fedora 19 Live CD (160MB/s transfer rate) and today I ran a full smartctl surface test and 0 errors found.

Comment 7 Hans de Goede 2014-08-04 17:59:42 UTC
Hi David,

Thanks for the logs. I think I know what is going on in your case. I've started a kernel scratch build with 2 patches added, once which I think / hope fixes things for your case, and one which adds some additional debugging in case it does not fix things.

This kernel is currently building here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=7240566

Once it is finished can you please download the kernel-3.15....rpm for your architecture, and then install it using: "sudo rpm -ivh kernel-3.15....rpm".

Then reboot into the new kernel and see if that fixes things. If it does not fix things, please collect dmesg output again.

Thanks,

Hans

Comment 8 Hans de Goede 2014-08-04 18:00:15 UTC
p.s.

Ronio, if you've an intel chipset with intel xhci controller, you may want to give this kernel a try too.

Comment 9 David 2014-08-04 20:13:06 UTC
Hi Hans,

thanks for your feedback. I proceeded as you instructed and the problem persists in the new kernel... I will just next attach the dmesg ouput where I followed the same steps as mentioned in my initial report.

Kind regards
David

Comment 10 David 2014-08-04 20:13:41 UTC
Created attachment 923999 [details]
dmesg output with new kernel

Comment 11 Hans de Goede 2014-08-12 16:06:44 UTC
Hi David,

Thanks for the new logs. Unfortunately the messages I was hoping were the cause are now gone (showing my patches fixed those), but unfortunately they were clearly not the cause :|

So this seems to be a case of the scsi later sending a command tripping up the disk and/or the usb<->sata convertor chip.

Can you try forcing use of the usb-storage driver instead of uas and see if that helps? To do this pass the following on the kernel commandline when booting:

usb-storage quirks=059b:0070:u

Thanks,

Hans

Comment 12 Hans de Goede 2014-08-12 16:08:40 UTC
Correction you should add the following to the kernel commandline:

usb-storage.quirks=059b:0070:u

Thanks,

Hans

Comment 13 David 2014-08-16 00:06:45 UTC
Hi Hans,

that kernel commandline solved the issue. The iomega/toshiba disk is now working fine and at normal USB 3.0 speeds. I was afraid another drive I have (Crucial SSD with SATA-USB 3.0 interface with UAS support) would not work at max speed with this workaround but it still works at nice 400MB/s transfer speeds. So thank you for providing a solution! :)

As I said before, this iomega drive worked fine in Fedora 19 so it's strange how this "regression" ocurred... any chance this is somehow patched in the kernel so this drive does not need kernel commands at boot time?

For the record I will attach the system log that says:

usb-storage 2-1:1.0: Quirks match for vid 059b pid 0070: 800000

Thanks,
David

Comment 14 David 2014-08-16 00:07:59 UTC
Created attachment 927279 [details]
dmesg output with kernel command: usb-storage.quirks=059b:0070:u

Comment 15 Justin M. Forbes 2014-11-13 15:56:43 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.17.2-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 21, and are still experiencing this issue, please change the version to Fedora 21.

If you experience different issues, please open a new bug report for those.

Comment 16 Richard Henderson 2014-12-10 22:36:48 UTC
I've been experiencing an oops with 3.17.4-301 that appears to
match these sets of error messages with rawhide 3.18.0-1:


[  598.175324] usb 2-2: new SuperSpeed USB device number 3 using xhci_hcd
[  598.187083] usb 2-2: New USB device found, idVendor=4971, idProduct=8017
[  598.187092] usb 2-2: New USB device strings: Mfr=10, Product=11, SerialNumber=3
[  598.187096] usb 2-2: Product: G-RAID
[  598.187099] usb 2-2: Manufacturer: HGST
[  598.187103] usb 2-2: SerialNumber: FD0131100312
[  598.194322] scsi host5: uas
[  598.195978] scsi 5:0:0:0: Direct-Access     HGST     G-RAID           0005 PQ: 0 ANSI: 6
[  598.199098] sd 5:0:0:0: Attached scsi generic sg2 type 0
[  598.199485] sd 5:0:0:0: [sdc] 7813857280 512-byte logical blocks: (4.00 TB/3.63 TiB)
[  598.199492] sd 5:0:0:0: [sdc] 4096-byte physical blocks
[  598.202054] sd 5:0:0:0: [sdc] Write Protect is off
[  598.202062] sd 5:0:0:0: [sdc] Mode Sense: 67 00 10 08
[  598.203306] sd 5:0:0:0: [sdc] Write cache: enabled, read cache: enabled, supports DPO and FUA
[  628.848231] sd 5:0:0:0: uas_eh_abort_handler 0 tag 2 inflight: IN 
[  628.848238] sd 5:0:0:0: CDB: 
[  628.848242] Report supported operation codes: a3 0c 01 12 00 00 00 00 02 00 00 00
[  628.848400] scsi host5: uas_eh_bus_reset_handler start
[  628.950747] usb 2-2: reset SuperSpeed USB device number 3 using xhci_hcd
[  628.961883] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801e0c07400
[  628.961889] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801e0c07448
[  628.961892] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801e0c07490
[  628.961895] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801e0c074d8
[  628.962648] scsi host5: uas_eh_bus_reset_handler success
[  659.925699] sd 5:0:0:0: uas_eh_abort_handler 0 tag 2 inflight: IN 
[  659.925708] sd 5:0:0:0: CDB: 
[  659.925712] Report supported operation codes: a3 0c 01 12 00 00 00 00 02 00 00 00
[  659.925814] scsi host5: uas_eh_bus_reset_handler start
[  660.028279] usb 2-2: reset SuperSpeed USB device number 3 using xhci_hcd
[  660.039759] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801e0c07400
[  660.039767] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801e0c07448
[  660.039772] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801e0c07490
[  660.039775] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801e0c074d8
[  660.040547] scsi host5: uas_eh_bus_reset_handler success
[  690.939024] sd 5:0:0:0: uas_eh_abort_handler 0 tag 2 inflight: IN 


$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Haswell-ULT DRAM Controller [8086:0a04] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:0a2e] (rev 09)
00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 09)
00:04.0 Signal processing controller [1180]: Intel Corporation Device [8086:0a03] (rev 09)
00:14.0 USB controller [0c03]: Intel Corporation 8 Series USB xHCI HC [8086:9c31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation 8 Series HECI #0 [8086:9c3a] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series PCI Express Root Port 1 [8086:9c10] (rev e4)
00:1c.3 PCI bridge [0604]: Intel Corporation 8 Series PCI Express Root Port 4 [8086:9c16] (rev e4)
00:1f.0 ISA bridge [0601]: Intel Corporation 8 Series LPC Controller [8086:9c43] (rev 04)
00:1f.2 RAID bus controller [0104]: Intel Corporation 82801 Mobile SATA Controller [RAID mode] [8086:282a] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 8 Series SMBus Controller [8086:9c22] (rev 04)
02:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev 6b)

$ lsusb
Bus 002 Device 003: ID 4971:8017 SimpleTech 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 03eb:8a0c Atmel Corp. 
Bus 001 Device 003: ID 1bcf:2987 Sunplus Innovation Technology Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Comment 17 Hans de Goede 2014-12-12 11:30:22 UTC
Hi,

(In reply to Richard Henderson from comment #16)
> I've been experiencing an oops with 3.17.4-301 that appears to
> match these sets of error messages with rawhide 3.18.0-1:
> 
> 
> [  598.175324] usb 2-2: new SuperSpeed USB device number 3 using xhci_hcd
> [  598.187083] usb 2-2: New USB device found, idVendor=4971, idProduct=8017
> [  598.187092] usb 2-2: New USB device strings: Mfr=10, Product=11,
> SerialNumber=3
> [  598.187096] usb 2-2: Product: G-RAID
> [  598.187099] usb 2-2: Manufacturer: HGST
> [  598.187103] usb 2-2: SerialNumber: FD0131100312
> [  598.194322] scsi host5: uas
> [  598.195978] scsi 5:0:0:0: Direct-Access     HGST     G-RAID          
> 0005 PQ: 0 ANSI: 6
> [  598.199098] sd 5:0:0:0: Attached scsi generic sg2 type 0
> [  598.199485] sd 5:0:0:0: [sdc] 7813857280 512-byte logical blocks: (4.00
> TB/3.63 TiB)
> [  598.199492] sd 5:0:0:0: [sdc] 4096-byte physical blocks
> [  598.202054] sd 5:0:0:0: [sdc] Write Protect is off
> [  598.202062] sd 5:0:0:0: [sdc] Mode Sense: 67 00 10 08
> [  598.203306] sd 5:0:0:0: [sdc] Write cache: enabled, read cache: enabled,
> supports DPO and FUA
> [  628.848231] sd 5:0:0:0: uas_eh_abort_handler 0 tag 2 inflight: IN 
> [  628.848238] sd 5:0:0:0: CDB: 
> [  628.848242] Report supported operation codes: a3 0c 01 12 00 00 00 00 02
> 00 00 00
> [  628.848400] scsi host5: uas_eh_bus_reset_handler start
> [  628.950747] usb 2-2: reset SuperSpeed USB device number 3 using xhci_hcd
> [  628.961883] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with
> disabled ep ffff8801e0c07400
> [  628.961889] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with
> disabled ep ffff8801e0c07448
> [  628.961892] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with
> disabled ep ffff8801e0c07490
> [  628.961895] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with
> disabled ep ffff8801e0c074d8
> [  628.962648] scsi host5: uas_eh_bus_reset_handler success
> [  659.925699] sd 5:0:0:0: uas_eh_abort_handler 0 tag 2 inflight: IN 
> [  659.925708] sd 5:0:0:0: CDB: 
> [  659.925712] Report supported operation codes: a3 0c 01 12 00 00 00 00 02
> 00 00 00
> [  659.925814] scsi host5: uas_eh_bus_reset_handler start
> [  660.028279] usb 2-2: reset SuperSpeed USB device number 3 using xhci_hcd
> [  660.039759] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with
> disabled ep ffff8801e0c07400
> [  660.039767] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with
> disabled ep ffff8801e0c07448
> [  660.039772] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with
> disabled ep ffff8801e0c07490
> [  660.039775] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with
> disabled ep ffff8801e0c074d8
> [  660.040547] scsi host5: uas_eh_bus_reset_handler success
> [  690.939024] sd 5:0:0:0: uas_eh_abort_handler 0 tag 2 inflight: IN 

Thanks for giving things a run with 3.18, as you've noticed 3.18 has greatly improved uas error handling, so that we actually get usable error logs instead of an oops.

Looking at the errors, things should work if you pass the following on the linux kernel commandline:

usb-storage.quirks=4971:8017:f

I think this should work with both recent 3.17 kernel and 3.18, please let me know if this helps, then I'll send a patch upstream adding a permanent quirk for your model drive to the kernel.

Comment 18 Richard Henderson 2015-01-09 18:47:08 UTC
Yes indeed, that quirk allowed 3.17.7-300 to mount the drive without oopsing.
Thanks.

Comment 19 Hans de Goede 2015-01-12 12:37:03 UTC
Hi,

(In reply to Richard Henderson from comment #18)
> Yes indeed, that quirk allowed 3.17.7-300 to mount the drive without oopsing.

Thanks for testing, I've send a patch with this quirk for your model upstream, and I've requested for it to be added to the official Fedora kernel builds.

Regards,

Hans

Comment 20 Josh Boyer 2015-01-12 13:54:04 UTC
Patch added.  Thanks Hans!

Comment 21 Fedora Update System 2015-01-14 13:14:31 UTC
kernel-3.18.2-200.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.18.2-200.fc21

Comment 22 Fedora Update System 2015-01-14 23:59:49 UTC
Package kernel-3.18.2-200.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.18.2-200.fc21'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0724/kernel-3.18.2-200.fc21
then log in and leave karma (feedback).

Comment 23 Fedora Update System 2015-01-19 20:49:12 UTC
kernel-3.18.3-201.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.18.3-201.fc21

Comment 24 Fedora Update System 2015-01-26 02:30:58 UTC
kernel-3.18.3-201.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 gerien 2015-02-06 11:47:08 UTC
Hi, 

I'm still experiencing those kernel freezes with a usb3 iomega drive during file transfers

I'm using the 3.18.5-201.fc21.x86_64 kernel

If you need more info, please ask me.

Cheers

$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller [8086:0150] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0152] (rev 09)
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4)
00:1c.1 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 [8086:1e12] (rev c4)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev c4)
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation Z77 Express Chipset LPC Controller [8086:1e44] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e02] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
03:00.0 PCI bridge [0604]: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge [1b21:1080] (rev 01)

$ lsusb
Bus 004 Device 003: ID 059b:0070 Iomega Corp. eGo Portable Hard Drive
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

$ dmesg
[ 1324.220095] usb 2-1: new SuperSpeed USB device number 4 using xhci_hcd
[ 1324.286049] usb 2-1: New USB device found, idVendor=059b, idProduct=0070
[ 1324.286053] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1324.286056] usb 2-1: Product: eGo USB
[ 1324.286058] usb 2-1: Manufacturer: Iomega
[ 1324.286060] usb 2-1: SerialNumber: 080000000001F961
[ 1324.371947] scsi host9: uas
[ 1324.378895] scsi 9:0:0:0: Direct-Access     OEM      Ext Hard Disk    0000 PQ: 0 ANSI: 5
[ 1324.644715] sd 9:0:0:0: Attached scsi generic sg2 type 0
[ 1324.743784] sd 9:0:0:0: [sdb] 1953504688 512-byte logical blocks: (1.00 TB/931 GiB)
[ 1324.892662] sd 9:0:0:0: [sdb] Write Protect is off
[ 1324.892668] sd 9:0:0:0: [sdb] Mode Sense: 10 00 00 00
[ 1324.938551] sd 9:0:0:0: [sdb] Cache data unavailable
[ 1324.938556] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[ 1325.482425]  sdb: sdb1
[ 1325.987131] sd 9:0:0:0: [sdb] Attached SCSI disk
[ 1326.722926] SELinux: initialized (dev sdb1, type fuseblk), uses genfs_contexts
[ 1332.036893] SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs

Comment 26 gerien 2015-02-06 11:50:24 UTC
Here is a log during a failing transfer

$ dmesg
[ 1712.838222] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 5 inflight: CMD OUT 
[ 1712.838228] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838229] Write(10): 2a 00 0e 8e 29 b8 00 00 48 00
[ 1712.838276] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 6 inflight: CMD OUT 
[ 1712.838278] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838279] Write(10): 2a 00 0e 8e 29 98 00 00 10 00
[ 1712.838441] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 7 inflight: CMD OUT 
[ 1712.838445] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838447] Write(10): 2a 00 0e 8e 29 68 00 00 10 00
[ 1712.838480] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 8 inflight: CMD OUT 
[ 1712.838482] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838483] Write(10): 2a 00 0e 8e 29 48 00 00 10 00
[ 1712.838514] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 9 inflight: CMD OUT 
[ 1712.838516] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838517] Write(10): 2a 00 0e 8e 27 d8 00 00 58 00
[ 1712.838611] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 10 inflight: CMD OUT 
[ 1712.838615] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838616] Write(10): 2a 00 0e 8e 27 88 00 00 18 00
[ 1712.838649] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 11 inflight: CMD OUT 
[ 1712.838651] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838652] Write(10): 2a 00 0e 8e 0a 28 00 00 08 00
[ 1712.838691] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 12 inflight: CMD OUT 
[ 1712.838693] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838694] Write(10): 2a 00 0e ac ac f8 00 04 00 00
[ 1712.838751] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 13 inflight: CMD OUT 
[ 1712.838753] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838754] Write(10): 2a 00 0e ac b0 f8 00 04 00 00
[ 1712.838820] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 14 inflight: CMD OUT 
[ 1712.838822] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838823] Write(10): 2a 00 0e ac b4 f8 00 04 00 00
[ 1712.838869] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 15 inflight: CMD OUT 
[ 1712.838871] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838872] Write(10): 2a 00 0e ac b8 f8 00 04 00 00
[ 1712.838896] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 16 inflight: CMD OUT 
[ 1712.838898] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838899] Write(10): 2a 00 0e ac bc f8 00 04 00 00
[ 1712.838937] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 17 inflight: CMD OUT 
[ 1712.838939] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838940] Write(10): 2a 00 00 00 de 50 00 00 08 00
[ 1712.838973] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 2 inflight: CMD OUT 
[ 1712.838975] sd 9:0:0:0: [sdb] CDB: 
[ 1712.838976] Write(10): 2a 00 0e ac c0 f8 00 04 00 00
[ 1712.839025] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 3 inflight: CMD OUT 
[ 1712.839027] sd 9:0:0:0: [sdb] CDB: 
[ 1712.839028] Write(10): 2a 00 0e ac c4 f8 00 04 00 00
[ 1712.839068] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 4 inflight: CMD OUT 
[ 1712.839070] sd 9:0:0:0: [sdb] CDB: 
[ 1712.839071] Write(10): 2a 00 0e ac c8 f8 00 04 00 00
[ 1712.839096] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 18 inflight: CMD OUT 
[ 1712.839098] sd 9:0:0:0: [sdb] CDB: 
[ 1712.839099] Write(10): 2a 00 0e ac cc f8 00 04 00 00
[ 1712.839136] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 19 inflight: CMD OUT 
[ 1712.839138] sd 9:0:0:0: [sdb] CDB: 
[ 1712.839139] Write(10): 2a 00 0e ac d0 f8 00 04 00 00
[ 1712.839226] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 20 inflight: CMD OUT 
[ 1712.839231] sd 9:0:0:0: [sdb] CDB: 
[ 1712.839232] Write(10): 2a 00 0e ac d4 f8 00 04 00 00
[ 1712.839307] sd 9:0:0:0: [sdb] uas_eh_abort_handler 0 tag 21 inflight: CMD IN 
[ 1712.839310] sd 9:0:0:0: [sdb] CDB: 
[ 1712.839311] Read(10): 28 00 0e 8e 2c 40 00 01 00 00
[ 1712.839392] scsi host9: uas_eh_bus_reset_handler start
[ 1712.949050] usb 2-1: reset SuperSpeed USB device number 4 using xhci_hcd
[ 1713.079736] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff88008bec3e00
[ 1713.079741] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff88008bec3e48
[ 1713.079744] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff88008bec3e90
[ 1713.079746] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff88008bec3ed8
[ 1713.148359] scsi host9: uas_eh_bus_reset_handler success

Comment 27 Hans de Goede 2015-02-07 09:02:55 UTC
Hi Gerien,

When you say "kernel freezes" what exactly do you mean ? Do you mean that apps accessing the disk become unresponsive, or something else ?

Have you checked that your usb-cable and harddisk powersupply are ok ?

Is the disk powered via usb, or through an external power supply ?

Regards,

Hans

Comment 28 gerien 2015-02-07 12:55:07 UTC
Sorry, I shouldn't have sayed "kernel freeze". During the file transfer, the transfer window indicates no more progress after a short time (a few seconds at most). And the log keeps growing with the same messages I copied earlier. It's impossible de stop the transfer. And if I try to unmount the disk using nautilus, I get a message saying that a file transfer is in progress and I shouldn't unplug the disk.

USB cable and harddisk powersuply seem OK. If I plug the disk with USB 2, it works almost perfectly (even if displayed file transfer speed is going from very high to very low)

The disk is powered via USB.