Bug 1124133

Summary: [RFE][horizon]: Add support for Spark in data processing UI
Product: Red Hat OpenStack Reporter: RHOS Integration <rhos-integ>
Component: python-django-horizonAssignee: Matthias Runge <mrunge>
Status: CLOSED ERRATA QA Contact: Ido Ovadia <iovadia>
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: aberezin, adahms, ajeain, aortega, jpichon, markmc, mrunge, rhos-flags, slong, ssainkar, yeylon
Target Milestone: Upstream M3Keywords: FutureFeature
Target Release: 6.0 (Juno)   
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/horizon/+spec/data-processing-spark-support
Whiteboard: upstream_milestone_juno-3 upstream_definition_approved upstream_status_implemented
Fixed In Version: python-django-horizon-2014.2-4.el7ost Doc Type: Enhancement
Doc Text:
With this update, the dashboard supports Spark EDP jobs for OpenStack Data Processing (sahara); the user can now add "Spark" as a job type when creating jobs. To support the new job type, help text has been added for Spark-job creation, appropriate configuration fields are hidden when launching a Spark job, and the job-type list is now translatable.
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-09 14:56:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description RHOS Integration 2014-07-29 04:04:40 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/horizon/+spec/data-processing-spark-support.

Description:

For Juno, Spark jobs will be supported in the Sahara data processing engine.  Given that, the data processing dashboard will need some changes to support the new job type.  

The corresponding Sahara-api spec can be found at:  https://review.openstack.org/#/c/109403/

The anticipated changes are as follows:
* add a new job type for Spark jobs (job creation)
* job launch config screen may have spark-specific fields included or non-applicable fields excluded (tbd)
* help text updated to include spark-specific notes as needed

Specification URL (additional information):

None

Comment 4 errata-xmlrpc 2015-02-09 14:56:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0154.html