Bug 1124140

Summary: document server REST API
Product: [Community] Beaker Reporter: Dan Callaghan <dcallagh>
Component: DocAssignee: Dan Callaghan <dcallagh>
Status: CLOSED CURRENTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 0.17CC: aigao, asaha, dcallagh, dowang
Target Milestone: 19.3Keywords: Documentation, FutureFeature, Patch
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-17 06:34:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1124139    

Description Dan Callaghan 2014-07-29 04:41:41 UTC
Since Beaker 0.15 for new client commands we have been adding "private"/undocumented HTTP APIs in the RESTful style, rather than continuing to add more XMLRPC methods.

Now that those APIs have been stable for a few releases (and are beginning to be used in spite of their undocumented status) we should document them and make them officially stable.

Comment 1 Dan Callaghan 2014-07-29 04:44:39 UTC
I think the only ones we have so far in 0.17 are:

POST /systems/<fqdn>/loans/
PUT /systems/<fdqn>/loans/+current
GET,PUT /systems/<fqdn>/access-policy
POST,DELETE /systems/<fqdn>/access-policy/rules/
GET /systems/<fdqn>/status

There are a bunch more which will be added for new-system-page (bug 1014438) as well.

Comment 3 Nick Coghlan 2014-09-24 10:34:32 UTC
As folks are starting to use these now, it would be good to get them properly documented for Beaker 19.

Comment 4 Dan Callaghan 2015-01-19 07:31:43 UTC
http://gerrit.beaker-project.org/3940

Comment 5 Dan Callaghan 2015-01-20 07:06:44 UTC
New server API docs are visible here:

https://beaker-project.org/docs-release-19/server-api/http.html

Comment 8 Dan Callaghan 2015-03-17 06:34:28 UTC
Beaker 19.3 has been released.